Update error [error 19]

Hi,
i have a problem with autoupdate hestia, always return “Error 19”

2019-12-11 01:43:23 v-update-sys-hestia ‘hestia’ [Error 19]
2019-12-11 01:43:38 v-update-sys-hestia ‘hestia-nginx’ [Error 19]
2019-12-11 01:43:52 v-update-sys-hestia ‘hestia-php’ [Error 19]
2019-12-11 16:34:10 v-update-sys-hestia ‘hestia’ [Error 19]
2019-12-11 16:34:22 v-update-sys-hestia ‘hestia-nginx’ [Error 19]
2019-12-11 16:34:33 v-update-sys-hestia ‘hestia-php’ [Error 19]
2019-12-11 16:35:13 v-update-sys-hestia ‘hestia’ [Error 19]
2019-12-11 16:35:24 v-update-sys-hestia ‘hestia-nginx’ [Error 19]
2019-12-11 16:35:35 v-update-sys-hestia ‘hestia-php’ [Error 19]

What does this error mean?

Is DNS resolution working OK? Could it be that the server can’t resolve the URL of the Hestia repository?

[email protected]:~# ping -c5 apt.hestiacp.com
PING apt.hestiacp.com (104.28.21.51) 56(84) bytes of data.
64 bytes from 104.28.21.51 (104.28.21.51): icmp_seq=1 ttl=50 time=47.1 ms
64 bytes from 104.28.21.51 (104.28.21.51): icmp_seq=2 ttl=50 time=45.6 ms
64 bytes from 104.28.21.51 (104.28.21.51): icmp_seq=3 ttl=50 time=45.5 ms
64 bytes from 104.28.21.51 (104.28.21.51): icmp_seq=4 ttl=50 time=45.5 ms
64 bytes from 104.28.21.51 (104.28.21.51): icmp_seq=5 ttl=50 time=45.5 ms

apt.hestiacp.com ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 45.526/45.887/47.181/0.702 ms
[email protected]:~# curl https://apt.hestiacp.com

403 Forbidden

403 Forbidden


nginx/1.14.0 (Ubuntu)

cat /etc/apt/sources.list.d/hestia.list
deb https://apt.hestiacp.com/ stretch main

v-update-sys-hestia only does a apt-get update and an apt-get install, if it fails you might have some previously interrupted installs/upgrades or something similar, which should be addressed first.

You can run the commands one by one and post the errors.

apt-get update -o Dir::Etc::sourcelist="sources.list.d/hestia.list" -o Dir::Etc::sourceparts="-" -o APT::Get::List-Cleanup="0"
apt-get install hestia
[email protected]:/etc/apache2/mods-enabled# apt-get update -o Dir::Etc::sourcelist="sources.list.d/hestia.list" -o Dir::Etc::sourceparts="-" -o APT::Get::List-Cleanup="0"
Hit:1 https://apt.hestiacp.com stretch InRelease
Reading package lists... Done
[email protected]:/etc/apache2/mods-enabled# apt-get install hestia
Reading package lists... Done
Building dependency tree       
Reading state information... Done
hestia is already the newest version (1.0.6).
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up php7.2-fpm (7.2.25-1+0~20191128.32+debian9~1.gbp108445) ...
NOTICE: Not enabling PHP 7.2 FPM by default.
NOTICE: To enable PHP 7.2 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.2-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Job for php7.2-fpm.service failed because the control process exited with error code.
See "systemctl status php7.2-fpm.service" and "journalctl -xe" for details.
invoke-rc.d: initscript php7.2-fpm, action "restart" failed.
● php7.2-fpm.service - The PHP 7.2 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2019-12-12 12:26:18 CET; 27ms ago
     Docs: man:php-fpm7.2(8)
  Process: 7159 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize --fpm-config /etc/php/7.2/fpm/php-fpm.conf (code=exited, status=78)
 Main PID: 7159 (code=exited, status=78)

Dec 12 12:26:18 daffyy.pro systemd[1]: Starting The PHP 7.2 FastCGI Process Manager...
Dec 12 12:26:18 daffyy.pro php-fpm7.2[7159]: [12-Dec-2019 12:26:18] WARNING: Nothing matches the include pattern '/etc/php/7.2/fpm/pool.d/*.conf' from /etc/php/7.2/fpm/php-fpm.c…f at line 125.
Dec 12 12:26:18 daffyy.pro php-fpm7.2[7159]: [12-Dec-2019 12:26:18] ERROR: No pool defined. at least one pool section must be specified in config file
Dec 12 12:26:18 daffyy.pro php-fpm7.2[7159]: [12-Dec-2019 12:26:18] ERROR: failed to post process the configuration
Dec 12 12:26:18 daffyy.pro php-fpm7.2[7159]: [12-Dec-2019 12:26:18] ERROR: FPM initialization failed
Dec 12 12:26:18 daffyy.pro systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=78/n/a
Dec 12 12:26:18 daffyy.pro systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager.
Dec 12 12:26:18 daffyy.pro systemd[1]: php7.2-fpm.service: Unit entered failed state.
Dec 12 12:26:18 daffyy.pro systemd[1]: php7.2-fpm.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package php7.2-fpm (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up php7.1-fpm (7.1.33-2+0~20191128.28+debian9~1.gbpc60685) ...
NOTICE: Not enabling PHP 7.1 FPM by default.
NOTICE: To enable PHP 7.1 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.1-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Job for php7.1-fpm.service failed because the control process exited with error code.
See "systemctl status php7.1-fpm.service" and "journalctl -xe" for details.
invoke-rc.d: initscript php7.1-fpm, action "restart" failed.
● php7.1-fpm.service - The PHP 7.1 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.1-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2019-12-12 12:26:20 CET; 14ms ago
     Docs: man:php-fpm7.1(8)
  Process: 8615 ExecStart=/usr/sbin/php-fpm7.1 --nodaemonize --fpm-config /etc/php/7.1/fpm/php-fpm.conf (code=exited, status=78)
 Main PID: 8615 (code=exited, status=78)

Dec 12 12:26:20 daffyy.pro systemd[1]: Starting The PHP 7.1 FastCGI Process Manager...
Dec 12 12:26:20 daffyy.pro php-fpm7.1[8615]: [12-Dec-2019 12:26:20] WARNING: Nothing matches the include pattern '/etc/php/7.1/fpm/pool.d/*.conf' from /etc/php/7.1/fpm/php-fpm.c…f at line 125.
Dec 12 12:26:20 daffyy.pro php-fpm7.1[8615]: [12-Dec-2019 12:26:20] ERROR: No pool defined. at least one pool section must be specified in config file
Dec 12 12:26:20 daffyy.pro php-fpm7.1[8615]: [12-Dec-2019 12:26:20] ERROR: failed to post process the configuration
Dec 12 12:26:20 daffyy.pro php-fpm7.1[8615]: [12-Dec-2019 12:26:20] ERROR: FPM initialization failed
Dec 12 12:26:20 daffyy.pro systemd[1]: php7.1-fpm.service: Main process exited, code=exited, status=78/n/a
Dec 12 12:26:20 daffyy.pro systemd[1]: Failed to start The PHP 7.1 FastCGI Process Manager.
Dec 12 12:26:20 daffyy.pro systemd[1]: php7.1-fpm.service: Unit entered failed state.
Dec 12 12:26:20 daffyy.pro systemd[1]: php7.1-fpm.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package php7.1-fpm (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up php7.0-fpm (7.0.33-13+0~20191128.24+debian9~1.gbp832d85) ...
NOTICE: Not enabling PHP 7.0 FPM by default.
NOTICE: To enable PHP 7.0 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.0-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Job for php7.0-fpm.service failed because the control process exited with error code.
See "systemctl status php7.0-fpm.service" and "journalctl -xe" for details.
invoke-rc.d: initscript php7.0-fpm, action "restart" failed.
● php7.0-fpm.service - The PHP 7.0 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.0-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2019-12-12 12:26:22 CET; 16ms ago
     Docs: man:php-fpm7.0(8)
  Process: 10003 ExecStart=/usr/sbin/php-fpm7.0 --nodaemonize --fpm-config /etc/php/7.0/fpm/php-fpm.conf (code=exited, status=78)
 Main PID: 10003 (code=exited, status=78)

Dec 12 12:26:22 daffyy.pro systemd[1]: Starting The PHP 7.0 FastCGI Process Manager...
Dec 12 12:26:22 daffyy.pro php-fpm7.0[10003]: [12-Dec-2019 12:26:22] WARNING: Nothing matches the include pattern '/etc/php/7.0/fpm/pool.d/*.conf' from /etc/php/7.0/fpm/php-fpm.…f at line 125.
Dec 12 12:26:22 daffyy.pro php-fpm7.0[10003]: [12-Dec-2019 12:26:22] ERROR: No pool defined. at least one pool section must be specified in config file
Dec 12 12:26:22 daffyy.pro php-fpm7.0[10003]: [12-Dec-2019 12:26:22] ERROR: failed to post process the configuration
Dec 12 12:26:22 daffyy.pro php-fpm7.0[10003]: [12-Dec-2019 12:26:22] ERROR: FPM initialization failed
Dec 12 12:26:22 daffyy.pro systemd[1]: php7.0-fpm.service: Main process exited, code=exited, status=78/n/a
Dec 12 12:26:22 daffyy.pro systemd[1]: Failed to start The PHP 7.0 FastCGI Process Manager.
Dec 12 12:26:22 daffyy.pro systemd[1]: php7.0-fpm.service: Unit entered failed state.
Dec 12 12:26:22 daffyy.pro systemd[1]: php7.0-fpm.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package php7.0-fpm (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up php5.6-fpm (5.6.40-14+0~20191128.24+debian9~1.gbpa5b195) ...
NOTICE: Not enabling PHP 5.6 FPM by default.
NOTICE: To enable PHP 5.6 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php5.6-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Job for php5.6-fpm.service failed because the control process exited with error code.
See "systemctl status php5.6-fpm.service" and "journalctl -xe" for details.
invoke-rc.d: initscript php5.6-fpm, action "restart" failed.
● php5.6-fpm.service - The PHP 5.6 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php5.6-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2019-12-12 12:26:24 CET; 15ms ago
     Docs: man:php-fpm5.6(8)
  Process: 11424 ExecStart=/usr/sbin/php-fpm5.6 --nodaemonize --fpm-config /etc/php/5.6/fpm/php-fpm.conf (code=exited, status=78)
 Main PID: 11424 (code=exited, status=78)

Dec 12 12:26:24 daffyy.pro systemd[1]: Starting The PHP 5.6 FastCGI Process Manager...
Dec 12 12:26:24 daffyy.pro php-fpm5.6[11424]: [12-Dec-2019 12:26:24] WARNING: Nothing matches the include pattern '/etc/php/5.6/fpm/pool.d/*.conf' from /etc/php/5.6/fpm/php-fpm.…nf at line 15.
Dec 12 12:26:24 daffyy.pro php-fpm5.6[11424]: [12-Dec-2019 12:26:24] ERROR: No pool defined. at least one pool section must be specified in config file
Dec 12 12:26:24 daffyy.pro php-fpm5.6[11424]: [12-Dec-2019 12:26:24] ERROR: failed to post process the configuration
Dec 12 12:26:24 daffyy.pro php-fpm5.6[11424]: [12-Dec-2019 12:26:24] ERROR: FPM initialization failed
Dec 12 12:26:24 daffyy.pro systemd[1]: php5.6-fpm.service: Main process exited, code=exited, status=78/n/a
Dec 12 12:26:24 daffyy.pro systemd[1]: Failed to start The PHP 5.6 FastCGI Process Manager.
Dec 12 12:26:24 daffyy.pro systemd[1]: php5.6-fpm.service: Unit entered failed state.
Dec 12 12:26:24 daffyy.pro systemd[1]: php5.6-fpm.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package php5.6-fpm (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 php7.2-fpm
 php7.1-fpm
 php7.0-fpm
 php5.6-fpm
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:/etc/apache2/mods-enabled#

One problem is missing php-fpm pool conf files, which was fixed here: v-rebuild-web-domains

If you are running 1.0.6 get the updated v-rebuild-web-domains script and execute it:

sudo su -
wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/bin/v-rebuild-web-domains -O /usr/local/hestia/bin/v-rebuild-web-domains
chmod +x /usr/local/hestia/bin/v-rebuild-web-domains
/usr/local/hestia/bin/v-rebuild-web-domains "admin"

1 Like