Upload database error 413

Hi! I want to import settings from WordPress. The file weighs approximately 300 mb. When I click import, I immediately get an error: > 413 Request Entity Too Large


my max file size is 2GB in ngnix settings along with php-fpm
The problem also occurs when importing the sql database.
I throw up my hands, I don’t know what to do to make it work.

in the file /etc/nginx/nginx.conf

http {
    # Main settings
    sendfile                        on;
    tcp_nopush                      on;
    tcp_nodelay                     on;
    client_header_timeout           300s;
    client_body_timeout             300s;
    client_header_buffer_size       2k;
    client_body_buffer_size         256k;
    client_max_body_size            1024m;
    large_client_header_buffers     4 8k;
    send_timeout                    600s;
    keepalive_timeout               30s;
    keepalive_requests              100000;
    reset_timedout_connection       on;
    server_tokens                   off;
    server_name_in_redirect         off;
    server_names_hash_max_size      512;
    server_names_hash_bucket_size   512;
    charset                         utf-8;

    # FastCGI settings
    fastcgi_buffers                 4 256k;
    fastcgi_buffer_size             256k;
    fastcgi_busy_buffers_size       256k;
    fastcgi_temp_file_write_size    256k;
    fastcgi_connect_timeout         30s;
    fastcgi_read_timeout            300s;
    fastcgi_send_timeout            180s;
    fastcgi_cache_lock              on;
    fastcgi_cache_lock_timeout      5s;
    fastcgi_cache_background_update on;
    fastcgi_cache_revalidate        on;
    # Proxy settings
    proxy_redirect                  off;
    proxy_set_header                Host $host;
    proxy_set_header                X-Real-IP $remote_addr;
    proxy_set_header                X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_pass_header               Set-Cookie;
    proxy_buffers                   32 4k;
    proxy_connect_timeout           600s;
    proxy_read_timeout              600s;
    proxy_send_timeout              600s;

I changed most things and it still doesn’t work.
Please help

Disable Cloudflare as it limits to max 100 mb


Thanks! it’s works…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.