Uploading nginx Web template – Permission denied!

Hi, I am having an issue uploading a new nginx Web template.

When uploading via SFPT, I got a permission denied message. I’m logged in as an admin user, and if I try using a CLI command, I will receive the following permission denied message when using the CLI Core Scripts…

[email protected]:~$ v-list-sys-ip
/usr/local/hestia/func/main.sh: line 1529: /usr/local/hestia/conf/hestia.conf: Permission denied

How do I solve this permissions issue?

Thanks!

System: Ubuntu 20.04, Hestia 1.60

Use root user

Thanks… I can’t log in with root!

ssh [email protected]
Please login as the user “ubuntu” rather than the user “root”.

Thanks

sudo -s after you are logged in via ubuntu

Sorry, this didn’t work…

[email protected]:/home/ubuntu# v-list-users
v-list-users: command not found

Thanks

Just full path

/usr/local/hestia/bin/v-list-sys-ips

or

/usr/local/hestia/bin/v-list-users

It worked, thanks. I’m still unable to upload a new nginx web template via SFTP because of the permission issue. I didn’t have this problem before with the 1.5.xx version of Hestia.

Thanks

By default only root user has write access to the templates folder. And that hasn’t been changed for ages…

Upload them to a folder your current user can write to and then use mv or cp

Thanks that worked great :slight_smile: