Use PHP-FPM instead of FastCGI (for Drupal)

Hello,

With a default HestiaCP installation, I have this message in a fresh install of Drupal 9:

Your server can’t display the progress of file transfers. This requires that PHP is executed with mod_php or PHP-FPM and not FastCGI.

What do I need to change in my conf files to use PHP-FPM? (I have googled)

Thanks

How old is your install?

I have install the server and HestiaCP just several month ago, in summer last year I think. It’s a Ubuntu 20.04.

//EDIT : the 15th august 2020

Then is should install by default with php-fpm enabled.

Run first:

And then

# locate migrate_apache.sh
/usr/local/hestia/install/upgrade/manual/migrate_apache.sh
# /usr/local/hestia/install/upgrade/manual/migrate_apache.sh
# locate migrate_mpm_event.sh
/usr/local/hestia/install/upgrade/manual/migrate_mpm_event.sh
# /usr/local/hestia/install/upgrade/manual/migrate_mpm_event.sh
mod_event is already enabled, canceling migration...

My version is:
Hestia Control Panel:
v1.3.2

Then PHP-FPM should be enabled. You should also get now an option to select you php version

See my screencaps here: The templates for Drupal 8 (or 9) aren't listed in GUI

I don’t know why I have this output un Drupal dashboard:

mod-fcgid?

apachectl -M

Loaded Modules:
core_module (static)
so_module (static)
watchdog_module (static)
http_module (static)
log_config_module (static)
logio_module (static)
version_module (static)
unixd_module (static)
access_compat_module (shared)
actions_module (shared)
alias_module (shared)
auth_basic_module (shared)
authn_core_module (shared)
authn_file_module (shared)
authz_core_module (shared)
authz_host_module (shared)
authz_user_module (shared)
autoindex_module (shared)
deflate_module (shared)
dir_module (shared)
env_module (shared)
fcgid_module (shared)
filter_module (shared)
status_module (shared)
mime_module (shared)
mpm_event_module (shared)
negotiation_module (shared)
proxy_module (shared)
proxy_fcgi_module (shared)
remoteip_module (shared)
reqtimeout_module (shared)
rewrite_module (shared)
rpaf_module (shared)
setenvif_module (shared)
socache_shmcb_module (shared)
ssl_module (shared)
suexec_module (shared)

You are using Apache2 + Nginx instead of Nginx as stand alone.

If php-fpm is enabled you should be able to pick the templates for PHP

dpkg -l -fpm | grep ii
ii php7.3-fpm 7.3.26-1+ubuntu20.04.1+deb.sury.org+1 amd64 server-side, HTML-embedded scripting language (FPM-CGI binary)
ii php7.4-fpm 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64 server-side, HTML-embedded scripting language (FPM-CGI binary)