V-change-domain-owner broke wordpress


i used the admin account to set up a full WordPress site with a custom theme and plugins, after reading this forum i noticed this was not the correct way ( i must have missed the Big Warning message while creating the domain :grinning:) site was working correctly prior to changing user.

to change over to new user i used:
v-change-domain-owner new.user this moved the domain with DNS and mail over to the new user. but left the Database behind. shouldn’t the DB tied to the domain also move over with this command?

I also used:
v-change-database-owner wordpress.db new.user
to move over the wordpress database over to the new user account. this also changed the db name from admin_wordpressDB to newuser_wordpressDB

next i changed the wordpress config.php lines :
define( ‘DB_NAME’, ‘newuser_worpressDB’ );

/** MySQL database username */
define( 'DB_USER', 'newuser_worpressDB' );

check site blank page on firefox , http errror 500 on chrome

go back to config.php turn on debug. still blank page.

i have also tried to rename the custom theme folder and the plugin folder of the wordpress site thinking they might be causing the issue but still no luck, turning on debug in wordpress config.php does not show any errors either.

Please check the error logs in /home/user/web/domain.tld/log

1 Like

Hi thank you for helping…

the domain.ltd.error.log:

[Thu Jan 28 01:52:04.009134 2021] [proxy_fcgi:error] [pid 9294:tid 140009088677632] [client] AH01071: Got error ‘PHP message: PHP Warning: Unknown: open_basedir restriction in effect. File(/home/admin/web/domain.ltd/public_html/wordfence-waf.php) is not within the allowed path(s): (/home/new.user/web/domain.ltd/public_html:/home/new.user/web/domain.ltd/public_shtml:/home/new.user/tmp:/var/www/html:/etc/phpmyadmin:/var/lib/phpmyadmin:/etc/phppgadmin:/etc/roundcube:/var/lib/roundcube:/tmp:/bin:/usr/bin:/usr/local/bin:/usr/share:/opt) in Unknown on line 0PHP message: PHP Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0PHP message: PHP Fatal error: Unknown: Failed opening required ‘/home/admin/web/domain.ltd/public_html/wordfence-waf.php’ (include_path=’.:/usr/share/php’) in Unknown on line 0’

seems like it is a plugin causing the issue, changing the setting inside .user.ini pointing it to the correct directory fixed the issue thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.