V-change-user-password - strange response

I restarted the VPS and cannot login to Hestiacp.
The websites that I set previousely work well.

I try to change pasword and get the following:
v-change-user-password admin NewPassword123
/usr/local/hestia/func/main.sh: line 1573: /usr/local/hestia/conf/hestia.conf: Permission denied
Error: user admin doesn’t exist
/usr/local/hestia/func/main.sh: line 102: /usr/local/hestia/log/error.log: Permission denied
$ sudo v-change-user-password admin NewPassword123
sudo: v-change-user-password: command not found

I see all the commands in /usr/local/hestia/bin and also I checked with less /etc/passwd and user admin does exit

What is wrong?
Thank you

Are you logged in as root?

sudo /usr/local/hestia/bin/v-change-user-password admin NewPassword123

or sudo -s
/usr/local/hestia/bin/v-change-user-password admin NewPassword123

Thank you eris.
I tried both. Does not work. See below:
$ sudo /usr/local/hestia/bin/v-change-user-password admin NewPassword123
/usr/local/hestia/func/main.sh: line 1573: /usr/local/hestia/conf/hestia.conf: P ermission denied
Error: invalid IP format :: /usr/local/hestia/bin/v-change-user-password
/usr/local/hestia/func/main.sh: line 102: /usr/local/hestia/log/error.log: Permi ssion denied
$ sudo -s /usr/local/hestia/bin/v-change-user-password admin NewPassword123

Changing password for admin.
chpasswd: (user admin) pam_chauthtok() failed, error:
Authentication token manipulation error
chpasswd: (line 1, user admin) password not changed
Error: Password not accepted due to PAM restrictions

Thank you kristankenney.
See below :slight_smile:

1 Like

Error: Password not accepted due to PAM restrictions

Use a different password NewPassword123 seems to be not allowed due to your pam restrictions or change the restorations in /etc/pam.d/

I tried a few different passwords, but get the same error:
Error: Password not accepted due to PAM restrictions

This is the code we run:


for a solution?

The server was behaving strangely and I abandoned it. On another server everything works fine.
Unlike in the past, it is not possible to login with a password that includes special characters, only letters and numbers.
Thank you very much for your help.

Special chars should be working fine make sure to use single quotes …