V-restart-service cronjob starts services that were stopped in hestiacp


So some months ago I started work with a new client and inherited installations of hestiacp on most of their servers. Hestiacp was installed in various configurations depending on the server functionality and I guess also who actually installed hestia. Fair enough.

I’ve installed hesticp once and now know that it can be installed with desired configs as needed, i.e. no anti-spam, vsftpd, dovecot since client or client’s clients don’t need or use those services.

I am posting because I have repeatedly disabled services in the hestiacp - will use dovecot as an example - that get restarted by v-restart-service even though they were disabled. Over and over again. Example:

2022-10-19 06:13:02 v-restart-service ‘dovecot’ ‘yes’
2022-10-19 09:36:52 v-stop-service ‘dovecot’
2022-10-20 06:13:02 v-restart-service ‘dovecot’ ‘yes’
2022-10-20 13:59:05 v-stop-service ‘dovecot’
2022-10-20 14:36:48 v-restart-service ‘dovecot’ ‘yes’
2022-10-20 14:36:48 v-restart-service ‘dovecot’
2022-10-21 06:13:04 v-restart-service ‘dovecot’ ‘yes’
2022-10-21 07:59:02 v-stop-service ‘dovecot’
2022-10-22 06:13:02 v-restart-service ‘dovecot’ ‘yes’
2022-10-23 06:13:03 v-restart-service ‘dovecot’ ‘yes’
2022-10-24 06:13:03 v-restart-service ‘dovecot’ ‘yes’
2022-10-25 06:13:03 v-restart-service ‘dovecot’ ‘yes’
2022-10-25 08:33:46 v-stop-service ‘dovecot’

On a dev server I disabled exim4 at the request of a developer that wanted to use postfix for some task. Did that but since then v-restart-service keeps trying to start exim4 which throws an error and sends an email that no one wants or needs.

So my question is is there a proper way to reliably disable a service that is disabled in the hestiacp such that it won’t be restarted by v-restart-service under any circumstances ? To be perfectly transparent I have masked the exim4.service on said dev server but this still throws an error and sends email on 1.6.10. Out of curiosity I tried the same procedure, the masking exim4, on another dev server with 1.6.8 and no error is thrown or email sent. I checked the 1.6.10 changelog and there is no change relevant to this.

Thanks in advance,


in /usr/local/hestia/conf/hestia.conf you have called a setting called:

Disable it by:



Thank You !


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.