V1.1.0 Templates - Where are they now?

I noticed that Templates were trimmed down to just 1-single template, which is default

What happens to the other? I can usually copy any of the apache web template and tweak to my liking.

My reason for find those is to tweak the php_admin_value - specifically the hosting.s/tpl template.

Hosting templates are still in: /usr/local/hestia/data/templates/web/apache2 but not selectable in admin dashboard under Web TemplateAPACHE2

Another question is - how could I change the post_max and upload_max values? Should I edit the main php.ini file for each php version?

System: Ubuntu 18.04

Depends to your used setup.

Also based on your setup, mostly just edit the default files located in /etc/php/[VERSION]/fpm/php.ini.

With that said, what type of setup to get these option under Web Template section?

I tried the default installer and also tried installing with the option to enable phpfpm. Both with same result - only default template shows up under Web Template.

I read the change log for 1.1.0 and does not talk about this one.

Also, I tried the upgrade route and the result is:
Web Template shows; default, hosting, phpcgi, phpfcgid.
And that is what I want to achieve - show those templates, which is not showing in version 1.1.0.

The same problem. I copy my template files in
/usr/local/hestia/data/templates/web/nginx/ , /usr/local/hestia/data/templates/web/apache2/
but my templates files not selectable.
I use standard setup:

bash hst-install.sh --port 1500 --multiphp yes

How I can use my own template files?

Templates location:

  1. Nginx Standalone with php-fpm backend (or multiphp):
    /usr/local/hestia/data/templates/web/nginx/php-fpm

  2. Nginx as proxy for apache2
    /usr/local/hestia/data/templates/web/nginx

  3. Apache with php-fpm backend or multiphp:
    /usr/local/hestia/data/templates/web/apache2/php-fpm

  4. Apache with built-in php:
    /usr/local/hestia/data/templates/web/apache2

  5. php-fpm or multiphp templates:
    /usr/local/hestia/data/templates/web/php-fpm

1 Like

In my case - this solves my problem. This is my current setup and actually saw that directory php-fpm but did not bother to check it out.

So, just copied the .s/tpl files to that directory and bam! Done.