V1.3.2~alpha to 1.4.3

Debian 10

I have an environment in the version v1.3.2~alpha and would like to upgrade to version 1.4.3

What would be the best way?

apt update && apt upgrade should do the job.

1 Like

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/ap ache2 buster InRelease: The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key [email protected]
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/ph p buster InRelease: The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key [email protected]
W: Failed to fetch https://packages.sury.org/apache2/dists/buster/InRelease The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Si gning Key [email protected]
W: Failed to fetch https://packages.sury.org/php/dists/buster/InRelease The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signin g Key [email protected]
W: Some index files failed to download. They have been ignored, or old ones used instead.

wget https://packages.sury.org/php/apt.gpg -O /etc/apt/trusted.gpg.d/php-sury.gpg
apt-get update && apt-get upgrade

Made the update, but it has several errors

wget https://packages.sury.org/php/apt.gpg -O /etc/apt/trusted.gpg.d/php-sury.gpg

Err:1 https://packages.sury.org/php buster/main amd64 php-pear all 1:1.10.12+submodules+notgz-1+0~20201204.17+debian10~1.gbp545cab
404 Not Found [IP: 104.21.18.148 443]
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php-pear/php-pear_1.10.12+submodules+notgz-1+0~20201204.17+debian10~1.gbp545cab_all.deb 404 Not Found [IP: 104.21.18.148 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Are you sure that apt update went trough properly?

The file has been saved in the folder

shortly thereafter

  • apt-get update && apt-get upgrade

[email protected]:/home/glpi# apt-get update && apt-get upgrade
Hit:1 http://deb.debian.org/debian buster InRelease
Hit:2 http://security.debian.org/debian-security buster/updates InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Get:4 https://packages.sury.org/apache2 buster InRelease [6,750 B]
Get:5 https://packages.sury.org/php buster InRelease [6,837 B]
Hit:6 http://ams2.mirrors.digitalocean.com/mariadb/repo/10.4/debian buster InRelease
Hit:7 http://repo.zabbix.com/zabbix/5.0/debian buster InRelease
Hit:8 http://nginx.org/packages/mainline/debian buster InRelease
Err:4 https://packages.sury.org/apache2 buster InRelease
The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key [email protected]
Err:5 https://packages.sury.org/php buster InRelease
The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key [email protected]
Hit:9 https://apt.hestiacp.com buster InRelease
Fetched 13.6 kB in 1s (11.9 kB/s)
Reading package listsā€¦ Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/apache2 buster InRelease: The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key [email protected]
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/php buster InRelease: The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key [email protected]
W: Failed to fetch https://packages.sury.org/apache2/dists/buster/InRelease The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key [email protected]
W: Failed to fetch https://packages.sury.org/php/dists/buster/InRelease The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key [email protected]
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package listsā€¦ Done
Building dependency tree
Reading state informationā€¦ Done
Calculating upgradeā€¦ Done
The following packages were automatically installed and are no longer required:
php5.6-opcache php5.6-readline php7.1-opcache php7.1-readline php7.2-opcache php7.2-readline
Use ā€˜apt autoremoveā€™ to remove them.
The following packages have been kept back:
linux-image-amd64 php-apcu
The following packages will be upgraded:
apt apt-utils awstats base-files bind9 bind9-host bind9utils ca-certificates curl debian-archive-keyring distro-info-data dnsutils file galera-4 grub-common grub-pc
grub-pc-bin grub2-common hestia iproute2 iputils-ping isc-dhcp-client isc-dhcp-common klibc-utils libapt-inst2.0 libapt-pkg5.0 libavahi-client3 libavahi-common-data
libavahi-common3 libbind9-161 libbsd0 libcairo2 libcups2 libcupsimage2 libcurl3-gnutls libcurl4 libdbi-perl libdns-export1104 libdns1104 libefiboot1 libefivar1 libgcrypt20
libglib2.0-0 libglib2.0-data libgnutls30 libhogweed4 libirs161 libisc-export1100 libisc1100 libisccc161 libisccfg163 libjpeg62-turbo libjs-jquery libjs-underscore libklibc
libldap-2.4-2 libldap-common liblwres161 liblz4-1 libmagic-mgc libmagic1 libmariadb3 libnettle6 libnss-systemd libopenjp2-7 libp11-kit0 libpam-systemd libpython3.7-minimal
libpython3.7-stdlib libsqlite3-0 libsystemd0 libtiff5 libudev1 libwebp6 libwebpmux3 libx11-6 libx11-data libzstd1 linux-libc-dev mariadb-client mariadb-client-10.4
mariadb-client-core-10.4 mariadb-common mariadb-server mariadb-server-10.4 mariadb-server-core-10.4 mysql-common nginx php-pear php7.3 php7.3-bcmath php7.3-bz2 php7.3-cli
php7.3-common php7.3-curl php7.3-fpm php7.3-gd php7.3-imap php7.3-intl php7.3-json php7.3-ldap php7.3-mbstring php7.3-mysql php7.3-opcache php7.3-pspell php7.3-readline
php7.3-soap php7.3-xml php7.3-zip python-apt-common python3-apt python3.7 python3.7-minimal sudo systemd systemd-sysv tzdata udev unzip zabbix-agent zstd
121 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 289 kB/77.2 MB of archives.
After this operation, 2,812 kB disk space will be freed.
Do you want to continue? [Y/n] Y
Err:1 https://packages.sury.org/php buster/main amd64 php-pear all 1:1.10.12+submodules+notgz-1+0~20201204.17+debian10~1.gbp545cab
404 Not Found [IP: 172.67.182.150 443]
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php-pear/php-pear_1.10.12+submodules+notgz-1+0~20201204.17+debian10~1.gbp545cab_all.deb 404 Not Found [IP: 172.67.182.150 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
[email protected]:/home/glpi#

Nope, still not good. Google is you friend: The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 - Google Suche

Solution to problem

update running normally

I appreciate the help @ScIT and @eris

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.