VSFTPD big file rename/move bug?

When i try to rename or move one big file above 10 GB by filezilla or winscp I get an 550 RNFR command failed. error
Files like 4-5 GB doesn’t have any problems so far I can see I can rename of move them without problem, all these files are belonging for the same user so I don’t think it is an permission error

Good afternoon Active8

Please use sftp (port 22 instead of 21) this more stable, more secure and saver. Also FileZilla and WinSCP supports it

Best regards

1 Like

Hi Eris, this has nothing to do with security or stability, server uploads and downloads fine with big files that isn’t the problem, problem is that vsftpd have problems with files bigger then 10 GB, you cant move or rename them !, just tested also with files big as 6 GB and not have any problems.

I am sure that this is an vsftpd bug, we have several servers with proftpd and pureftpd ftp server and never had this problems with big files like vsftpd

@eris just pointed to sftp, which is more secure and stable than vsftpd - he did not wrote that your issue is in any case related to security.

Also if it is a vsftps issue, as you think it is (can’t test it from my side, using sftp here and don’t have such big files ready), maybe the vsftpd forum/issue tracker would be the right place.

Also from my side: Please consider to switch to sftp, as @eris wrote, it is also supported from filezilla.

Hi ScIT , yes i know that sftp is far more secure but as said that is not the problem.
all files bigger then 10 GB that are uploaded to this server has problems, uploading is fine , but try to create a directory and move this file in or try to download give this error

Another problem is that VSFTPD is not development anymore since July 2015 !
they don’t have any forum or whats ever to report this

At this moment we are doing a workaround by splitting files but this is not really what we want
Is there any plans to change to proftpd or pureftpd in the future ? purely because vsftpd seems abonded

Since the files are so big, you might be hitting a timeout and the command is getting dropped.

I’d look into what you can set in your vsftpd.conf file.

Here’s a link to your options: http://vsftpd.beasts.org/vsftpd_conf.html

I’d suggest trying to adjust the data_connection_timeout option.

Otherwise, it’s likely a vsftpd bug of sorts.

1 Like

Run the installer with --vsftpd no --proftpd yes and you will get proftpd :slight_smile:.

1 Like

You can also use –proftpd yes in the installer to get proftpd.

other switches can be found here: https://docs.hestiacp.com/getting_started/all_installation_options.html

1 Like

Hi cmstew,
! don’t have any problems with upload or timeouts , files big as 10 GB is uploaded fine without any problems, and I see them fine in filezilla
Problem is: I cant move or rename them nor download them

We are new to Hestia, can you give me the full command line in Terminal please ?
Any files or directory that are created will remains as it is when doing the upgrade ?

Check the install documentation: https://github.com/hestiacp/hestiacp/blob/master/README.md#custom-installation

A migration from vsftpd to proftpd is possible, probaly this steps here should be enough - not tested on my own!

How to replace vsftpd with ProFTPD on a Debian or Ubuntu

  1. Disable vsftpd

service vsftpd stop
update-rc.d -f vsftpd remove

  1. Install software package

apt install proftpd-basic proftpd-mod-vroot

  1. Download configuration

wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/install/deb/proftpd/proftpd.conf -O /etc/proftpd/proftpd.conf

  1. Change hestia settings

sed -i s/vsftpd/proftpd/ /usr/local/hestia/conf/hestia.conf

  1. Restart proftpd

service proftpd restart

1 Like

Yes, you won’t be able to use the installer to upgrade. It’ll have to be done manually. But if one day you want to use the installer, you’ll want to do something like this on a fresh debian/ubuntu distro:

bash hst-install.sh --vsftpd no --proftpd yes

gives error here : sed: -e expression #1, char 1: unknown command: `▒’

you can just open that file up and replace vsftpd with proftpd manually.

1 Like

Wrong fromat for ", fixed it.


Ok, not fixable, it always takes the wrong one due to format - I removed them, should also work.

Thanks it works now, any chance that this will be default for Hestia in the future ?

Default should be sftp, not ftp/s - currently there is no change planed, you’ve the free choose during installation.

1 Like

I also propose to not install any ftp servers by default, curently vsftpd is installed by default

1 Like

To better understand the issue, could you also check if you get the same error when using sftp, and let us now the results?

1 Like