Webmail gives error 404

When I click to view emails via webmail.mydomain.com I get this error.
Can you tell me what’s wrong?

Page Not Found

Oops! We couldn’t find the page that you’re looking for.
Please check the address and try again.
Error Code: 404

Do you have a DNS A record for “webmail” subdomain pointing your main IP address?

Out of discord chat:

Let me tell you easy way to fix it

Go to mail domain, Edit it.
Disable webmail client and save.
Then again eneble it and save.

Booooommm it will work, Single 30 sec work stuck_out_tongue_closed_eyes

We have to check why it happens.

2 Likes

I think I know what is going wrong but instead fix it an release the patch my plan is to setup a CI/CD platform write the tests for it and then fix the bug …. I know the last part takes 10 times more time but will help us in the future….

1 Like

Fresh install from yesterday. I try disabling webmail (in order to solve the 404) and get this error message:“Error: nginx restart failed”, in X.X.X.X:8083/edit/mail/?domain=xxxx.tld

It basically won’t allow me to disable webmail for that (only) domain.

AFAIK nginx is now down. It seems caused by disabling webmail (?). Not a webmail access problem now but server one.

sudo systemctl status nginx
● nginx.service - nginx - high performance web server
     Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sun 2021-07-18 09:49:09 UTC; 6min ago
       Docs: https://nginx.org/en/docs/
    Process: 321486 ExecStart=/usr/sbin/nginx -c /etc/nginx/nginx.conf (code=exited, status=1/FAILURE)

Jul 18 09:49:09 XXX.example.com systemd[1]: Starting nginx - high performance web server...
Jul 18 09:49:09 XXX.example.com nginx[321486]: nginx: [emerg] cannot load certificate "/home/xxx/conf/mail/xxxxxx.com/ssl/xxxxxxx.com.pem": BIO_new_file() failed (SSL: error>
Jul 18 09:49:09 XXX.example.com systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
Jul 18 09:49:09 XXX.example.com systemd[1]: nginx.service: Failed with result 'exit-code'.
Jul 18 09:49:09 XXX.example.com systemd[1]: Failed to start nginx - high performance web server.

Disable ssl and it should be fine then.

Will setup https://www.drone.io/ today and write the required test for it to debug / test it better and for in the future….

After that fix the bugs inside it…

1 Like

Deleting mail address and deleting whole domain did not solve the nginx issue (!). Deleting user and recreating it, did the trick for the server to be back but still no way to access webmail (server not found). Hope it helps to find out the issue.

SSL is disabled and no webmail so far. When I did the ‘de-activate - activate thing’ is when nginx went down. I’m in NO hurry, as I’m actually ‘playing’ with your panel to get used to it before I decide if going with it for production. And in that case I won’t probably be using mail from here. I’m just testing now. Ty

do a nginx -t and check the error output, it will provide additional informations.

I get an OK now, for I have already deleted (and recreated) user:

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

Ah ok, usualy when you get that error message, run that command so you can see where exactly it fails :slight_smile: .

ok, thank you. I may try again to switch SSL on and off (now it’s off) and check if I can access webmail… or run into the same ‘server down’ issue. I’ll report it here. So far SSL is off and webmail sends to ‘server not found’ page.

BTW, as you may have realized, I’m very illiterate regarding VPSs, linux, etc. but (maybe for that reason) I can be a cool tester :-D. If I ever do any stupid comment, please let me know or don’t care much about me, ok?

Sorry to annoy. I feel I shouldn’t be making anyone lose time.
So far everything working but access to webmail (one only address for one only domain and single user, besides admin).

I have SSL over the domain via Let’s Encrypt. When I try to switch to SSL in mail I get the following error message: “Error: DNS record for mail.xxxxxx.com doesn’t exist”. I check the DNSs at Hestia panel and they appear there (both for mail. & webmail.). I am only trying to switch on and off SSL in order to bring webmail to life. Not sure if I should do any changes at my domain provider, but I guess not.

In brief:

  • domain with SSL
  • mail without SSL (DNSs error message)
  • nginx server UP
  • webmail page down

This problem started along with frequent Let’s encrypt 400 errors, and nginx failing to restart after changes (I don’t know If it was with version 1.4.6 or 1.4.7). The workaround I found helpful was restarting nginx manually after (or before) every change.
Something that’s quite impossible for unprivileged user.

We have released an patch that solves the issue

1 Like

This fix works, but after nginx restart.