Webmail isn't working again!


The title says it all. I installed the CP on a new server but got shocked when webmail isn’t working on any OS …! Debians 10 and 11 nor ubuntu versions 20 and 22 :no_entry:

The NGNIX log says:

2022/10/05 18:27:43 [warn] 7509#7509: “ssl_stapling” ignored, issuer certificat$

Not sure what is happening.

PS. Have done same OS installation several times and changed slightly methods, and yet no go!

Mean you are using a self generating ssl certficate some where…

I had to because letsencrypt didn’t go through with webmail only besides domain which was installed perfectly!

Should I revoke it or keep it and revoke web domain letsencryp?? Or your pick.

EDIT: Even not using ssl whatsoever webmail doesn’t open and keeps coming back error page!

K, this time united all ssl with one letsencrypt and had no errors in the NGUNX directory :face_with_diagonal_mouth:

What could be the problem now???

What means “isnt working”? Way to less informations to tell anything…

page isn’t opening = not working m8

page isnt opening != not working. Page doesnt open due to what? Timeout? Gateway Error? DNS Issue? Blank page only? Error message? Its impossible to help you if you dont provide more informations.

This is what I want to know and tried everything possible. Then, decided to share it here hoping someone might have an idea to overcome this problem as shown in the still image below:


Looks like an DNS issue.

nslookup webmail.domain.com

1 Like

I was 99% sure of that but I’m 100 now since you concurred it…!

I reset my zones since it was a mess and will return after 24 hrs to set it up again :eyes:

Many thanks bro and always there to rescue :game_die:

I have upgraded ubunto from 20.04 to 22.04 and now I cant use webmail. I get error. I have reinstalled hesiaCP also.

/var/log/domains/webmail.domain.com.error.log file

2022/10/11 16:01:53 [error] 160290#160290: *104982 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to undefined function mb_internal_encoding() in /var/lib/roundcube/program/lib/Roundcube/bootstrap.php:86
Stack trace:
#0 /var/lib/roundcube/program/include/iniset.php(78): require_once()
#1 /var/lib/roundcube/index.php(40): require_once('...')
#2 {main}
  thrown in /var/lib/roundcube/program/lib/Roundcube/bootstrap.php on line 86" while reading response header from upstream, client:, server: webmail.domain.com, request: "GET /?_task=mail&_mbox=INBOX HTTP/2.0", upstream: "fastcgi://", host: "webmail.domain.com"

/var/log/roundcube/errors.log file

[10-Oct-2022 12:07:46 +0300]: <gsmgr6lc> PHP Error: Invalid response code received from server (POST /?_task=mail&_unlock=loading1665392866227&_framed=1&_action=send)
[10-Oct-2022 12:07:46 +0300]: <gsmgr6lc> SMTP Error: Failed to add recipient '[email protected]': Temporary local problem - please try later (Code: 451) in /var/lib/roundcube/program/lib/Roundcube/rcube.php on line 1795 (POST /?_task=mail&_unlock=loading1665392866227&_framed=1&_action=send)

[10-Oct-2022 12:14:07 Europe/Moscow] PHP Warning:  Undefined array key "ssl_mode" in /var/lib/roundcube/program/lib/Roundcube/rcube_imap_generic.php on line 1053

Looks like mbstring module is missing, also reinstall hestia isnt a great idea - you can try to install it, but it depends on the php version used for www.conf. You can find it when you search the file in /etc/php/x.x/fpm/pool.d/ (or similar, on mobile right now). Maybe, as you’ve reinstalled hestia over it, it would be faster to take backups, format the server, install hestia and restore the backups.

I updated php-mbstrings and currently webmail is opened and I signed in to my email account.

sudo aptitude update
sudo aptitude -y install php-mbstring

But currently I can’t send email I get error.

SMTP Error (451): Failed to add recipient "[email protected]" (Temporary local problem - please try later)

Check https://docs.hestiacp.com, there is a upgrade section.

1 Like

thank you I solved with this commands.

rm -f /etc/exim4/exim4.conf.template
cp -f /usr/local/hestia/install/deb/exim/exim4.conf.4.94.template /etc/exim4/exim4.conf.template