Webmail not accessible after migrating from VestaCP

I’ve just migrated a VestaCP VPS to another VPS with the latest version of HestiaCP.

Everything worked like a charm thanks to this great community so far, except for the webmail.

The way to access to webmail (roudncube) VestaCP was through the URL “mydomain.com/webmail” and I think in HestiaCP is through “webmail.mydomain.com”, because when I type the first method I get a 404 Not-found code.

When I type the subdomain, it is simly not able to find it. Not even with a ping.

As far as I see in the DNS, subdomain “webmail” is not even listed, so I’ve added an A record but still does not seem to work.

Any clue on what I’m doing wrong?

Thank you in advance.

Yes, that’s right.

Did you add your domain as mail domain?

Yes, they are all listed there.

I’ve just entered to each mail domain settings and I’ve spotted that SSL is not enabled, but when I try to enable it I get the message that “DNS webmail does not exists”. I’ve created an A record “webmail” that points to the IP address of the server, but when I try to enable SSL again, HestiaCP keeps giving me the same error.

Any clue?

What’s your actual domain? If you don’t want to share it publicly, send me a private message.