Webmail showing index.php as source

Hi,
I am on debian 10 with hestia 1.4.17 running. (apache2 + nginx)
I know for sure that webmail.domain.xyz worked a few weeks ago (unfortunately I use webmail rarely so I cannot tell when that changed).
DNS is correct and as said - it surely already worked but yesterday I had to use webmail again and discovered that the webmail only shows the source of the index.php file.
I than tried to switch between rainloop and roundcube (both showed their respective index.php as source)
As I found in another thread where that happend that also phpmyadmin and phppgadmin were not using php I tested this too, but to my surprise phpmyadmin and phppgadmin were correctly showing up.
So it is only webmail which obviously does not use php to process the page source.

Any hint where I can search?
Thanks a lot
Werner

Is php7.4 installed?

there is
php5.6
php7.0
php7.1
php7.2
php7.3
php7.4
php8.0
installed, but only 7.4 and 8.0 are activated and used.

Does www.conf exists in one of the /etc/php/x.x/fpm/pool.d?

yes it does but only in 7.4/fpm/pool.d/www.conf

with the content:

; origin-src: deb/php-fpm/www.conf

[www]
listen = 127.0.0.1:9000
listen.allowed_clients = 127.0.0.1

user = www-data
group = www-data

pm = ondemand
pm.max_children = 4
pm.max_requests = 4000
pm.process_idle_timeout = 10s

That should be correct

still after several reboots
phpmyadmin works but
webmail does not

the only difference i can see is that its
domain.tld/phpmyadmin whereas
webmail.domain.tld

but where can the problem hide? Everything else on that installation works.

Maybe I should also add that I did not change anything manually - it’s all hestia automatic …

@macho try running $HESTIA/install/upgrade/manual/migrate_mpm_event.sh

had a similar issue in the past, hope this fix the issue.

Hi @alber
Thanks a lot for sharing that information.
Webmail works perfectly again.
Now I have to take a closer look where the problem was.

3 Likes

I think the issue was that apache was using mpm_prefork instead of mpm_event