Webmail shows SUCCESS after restoring from backup

Hi All,

ENVIRONMENT

  • OS: Ubuntu 22.04 LTS
  • HestiaCP version: 1.6.11
  • DNS A-records correctly created (webmail.<mydomainname.com> and mail.<mydomainname.com>)
  • SSL certificate: created and working

ISSUE:

  • If I click on the the Open Webmail icon that appears once I hoover the mouse on my mail domain in the MAIL section, then the page https://webmail.<mydomainname.com> is loaded but instead of seeing the Roundcube web mail UI login I see the index.php default page saying Success!
  • However, if I manually add the “/?_task=mail&_mbox=INBOX” suffix to the URL of my web mail domain, the correct Roundcube web mail UI login appears:

ADDITIONAL DETAILS

  • My instance of HestiaCP is running in a VPS which offers full snapshot revert as well as boot volume and block volume backup / restore
  • The above issue happens after I revert the snapshot of my VPS or I perform a restore from backup to a well working state of my VM
  • I can successfully login to my Roundcube web mail UI login though

I am pretty sure there’s a couple of Hestia built-in scripts I can use to reset this situation and resolve this issue.

Can please someone help me on this?

Thanks.

Regards.

Ivano

maildomain is domain.tld, not webmail.domain.tld. mail.domain.tld and webmail.domain.tld gets generated automatically.

at least according this screenshot it looks like you did:
https://forum.hestiacp.com/uploads/default/original/2X/7/7bd8d5bd720f027dc98e1cc444dcd0ec3872c16d.png

infact you were able to generate ssl certs, probaly the screenshot is missleading. Have you tried to open in incognito? looks like a caching issue.

I’m not entirely sure what you mean by that.

I have deployed HestiaCP in staging as well as in production environment for many many web mail and everything works correctly. Perhaps my level of details above is not enough despite my screenshots.

  1. From the MAIL section of my HestiaCP deployment I see xxxxxxx.yyy (as you can see this is very generic but obviously I can reveal my real mail domain)
  2. Typically - as an HestiaCP user (hence as an owner of my own mail domain) - when I click on my xxxxxxx.yyy mail domain (from the MAIL section), assuming I have a DNS A-record created for webmail.xxxxxxx.yyy and mail.xxxxxxx.yyy and I also have a valid SSL certificate created, the minute I click on the Open Webmail icon, I get redirected automatically to the Roundcube page. Well this is not happening as I get the Success! page instead.
  3. However, If I add the “/?_task=mail&_mbox=INBOX” suffix (as explained above), then I see the correct Roundcube web page

How come? Before the restore this was working fine.

Please note that the above is in my staging environment. This issue is not happening in my production environment.

infact you were able to generate ssl certs, probaly the screenshot is missleading. Have you tried to open in incognito? looks like a caching issue.
So small update. If I clear the cache and the cookies the issue still occurs. However, the issue does not occur if in incognito mode
@ScIT - your suggestion worked. So I’m going to reset my Internet browser and see what happens.
Thanks for the advise!

For clear your browser cache should help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.