Website isn't loading

Hi everyone,

First of all, I would like to say thank you for Hestia CP.

I just installed it on a VPS running Ubuntu 18.04. I followed the standard installation guide from hestiacp.com

As far as I can tell, everything worked as expected. After the installation and restart, I was not able to access the hestia panel using the IP:8083 address. But after a couple of minutes it worked.

Now I have installed Wordpress on a domain name, using the Quick App Installer and did not get any error messages. But I can not access the site for some reason. It just won’t connect and says “refused to connect”

Any help would be greatly appreciated. I really need to setup this site.

Please delete the domain and create a new, blank one. Then check if you can access it, it should always show you the default page. Please let us know if you got this working - if not, there is a wide sector with possible configurations like dns and so on, but to find this out, we would need to have more informations about your system.

1 Like

Sorry, it was a dumb mistake. I did not setup SSL for this site, and my browser was automatically trying to access the https version of the site.

It is working without https but now the WordPress is complaining about the PHP version being old. It is on version v7.3.19. I looked under the “Backend template” for this domain and it only has “no-php” “PHP-7_3” and “socket”

The WordPress REST API is also complaining about unexpected result: (429)

Any thoughts where I should look?

Found the multi-php selection options in the ip:8083/edit/server and enabled the PHP 7.4

Perfect, just wanted to write about to enable php74 :smiley:. About the other issue, I don’t have an idea, muliple wordpress installations are working properly here - just migrated to 7.4 as well due to the “error” message.

I have the domain still pointed towards the old hosting and I am restoring the backup using the hestiacp IP in the hosts file. This is probably why it’s not working because wordpress is trying to access the domain and reaching a different server.

How can I enable server-side caching like redis and memcached? I have 16GB RAM and only plan to host 1 site, so it would be nice to have the pages cached in the memory for faster speeds.

Like you would do it on a default system as well, you can basicly just follow every tutorial :smiley:.

1 Like

Ok, thats great. But it would be nice to have a step by step tutorial for it on this forum. I will probably write a rough guide for others after I have it running on my server successfully.

@ScIT
Is 1.1.1 the latest stable release of HestiaCP? This is the version it installed automatically and I see the v1.2 is also out?

https://docs.hestiacp.com/admin_docs/server_management.html#how-to-install-additional-php-packages-modules

For redis you will need to install also redis-server

1 Like

Thanks for that. :slight_smile:

v1.2 will be (re-)released on monday, the current stable is 1.1.1.

1 Like

Awesome. Thanks for the update.