Websites unavailable after 1 day

Hello I have the following problem. The websites all go offline after about a day although Apache and Mysql are running. You can still get into the panel and everything looks fine.
Yesterday the server was restarted and the websites still stayed offline. After 30 minutes without doing anything everything went online again.
The problem occurs now only after I updated Hestiacp from 1.2.4 to 1.3.2.

Another error I found in Hestia SSL at ISSUER: C = US, ST = California, L = San Francisco, O = Hestia Control Panel, OU = IT, CN = server.domain2.com, emailAddress =
Suddenly there is another domain in here. “Server.” is correct but domain2.com is not correct. Why did this change? I do not know since when the change is in the domain also runs on the server but has nothing to do with the panel. If the server crashes because of this I can’t say.

Errorlogs:

2021-01-07 13:34:56 0 [ERROR] InnoDB: (Duplicate key) writing word node to FTS auxiliary index table.
2021-01-07 13:34:56 0 [Note] InnoDB: FTS optimize thread exiting.
2021-01-07 13:34:56 0 [Note] InnoDB: Starting shutdown…
2021-01-07 13:34:56 0 [Note] InnoDB: Dumping buffer pool(s) to /var/lib/mysql/ib_buffer_pool
2021-01-07 13:34:56 0 [Note] InnoDB: Buffer pool(s) dump completed at 210107 13:34:56
2021-01-07 13:34:58 0 [Note] InnoDB: Shutdown completed; log sequence number 124208327823; transaction id 294646515
2021-01-07 13:34:58 0 [Note] InnoDB: Removed temporary tablespace data file: “ibtmp1”
2021-01-07 13:34:58 0 [Note] /usr/sbin/mysqld: Shutdown complete

Apache:

[Sat Jan 09 15:38:18.677721 2021] [mpm_prefork:error] [pid 1128] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting

Sat Jan 09 15:38:18.677721 2021] [mpm_prefork:error] [pid 1128] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting

Good starting point

that doesn’t help me at all. worker_connections is set to 1024. as I said with HestiaCP 1.2.4 it ran without problems.

We haven’t change any regarding Apache2 / max workers in any Apache2 config

Only: * Updated Apache2 configuration to use Include with IncludeOptional (#1072)

See

But what is the main reason still running in prefork?

Maybe someone has an idea or can confirm the problem. Until then, I’ll watch the whole thing a bit more whether it continues to occur.

How could one return to the 1.2.4 if necessary? Or is that not possible.

And one more error I just found:
in error_reporting the following is entered:
E_ALL |E_ALL |E_ALL |E_ALL & ~E_DEPRECATED & ~E_STRICT& ~E_DEPRECATED & ~E_STRICT& ~E_DEPRECATED & ~E_STRICT& ~E_DEPRECATED & ~E_STRICT

I doubt that I have written so many E_ALL myself. Something is stored twice.

You can’t downgrade to a lower hestia version, this isnt supported. Also as @eris already pointed out, there were no changes from 1.2.4 to 1.3.2 for apache2. What do you run exactly? Apache2+Nginx?

As @eris also pointed out is that you’re still running on mpm_prefork - fpm has a much better performance and is since 1.1.1 (!) the default for any new hestia installation. Please consider to run the manual migration script, you’ll find the needed informations here: https://docs.hestiacp.com/release_notes/archive/1.1.0.html#new-multiphp-system

No idea about your other point about the “new” domain, hestia doesnt change anything automatically :slight_smile:.

Also:

  • Improved Apache2 performance by switching to mpm_event instead mod_prefork by default for new installations.
  • Added a manual migration script for apache2 mpm_event for existing installations/upgrades ($HESTIA/install/upgrade/manual/migrate_mpm_event.sh).
1 Like

Also check

1 Like

Unfortunately it runs via prefork although I have HestiaCP installed since 1.1.1. Then I have to change that.

the domain change can only come from the system. i do not even know how to change that, there is no function to change!:slight_smile:

thank you both.

Mpm event was enabled in 1.2 of Hestia

1 Like

so i took a look at the file it says “a2modules=“php5.6 php7.0 php7.1 php7.2 php7.3 php7.4 ruid2 mpm_itk mpm_prefork””

php 8.0 is missing. does it still work?

what command do i use to perform the update? like this?

sudo chmod +x /usr/local/hestia/install/upgrade/manual/migrate_mpm_event.sh

Probably you should add php8.0

After that:
sudo ./usr/local/hestia/install/upgrade/manual/migrate_mpm_event.sh

1 Like

@Meister any update? Is the server now running properly?

at the moment the server runs without problems. but i haven’t switched to Mpm event yet. however i have set the max_execution_time to 120, before it was unlimited.

That would explain a lot - unlimited execution time would overload the server on bad written scripts. Glad you found it out, even when “unlimited” isnt hestia’s default value :grin:.

1 Like

problem is that i have a cronjob that needs a longer execution time. the script is located in /var/www/html

is there a way to increase the max_execution_time for this folder?

Use CLI :slight_smile:

1 Like

or increase the value, but dont set it tl unlimited. But cli is the better way because it’s unlimited by default.

thanks for the tip about cli it just worked. then the default limits can stay in:)