Wget, curl or GET con jobs commands are not wokring

Hi all,

can anyone please help me figure out why the other alternate commands not working in Hestia CP > USER > CRON?

I’ve been using this command below all the time and it’s working fine:
php /home/biobrus/web/biobrusinka.cz/public_html/wp-content/plugins/mailster/cron.php 2b7fff1e83eba2fc16b4e92250308d66 > /dev/null

However, I am having some troubles with duplicate emails being sent to subscribers and Mailster support asked me to use one of these methods below instead:
wget -O- ‘Mailster 3.2.0 - Cron’ > /dev/null
curl --silent ‘Mailster 3.2.0 - Cron
GET ‘Mailster 3.2.0 - Cron’ > /dev/null



I cannot get any of these 3 methods working. Can anyone explain why that is and how to get it working, please?

Thank you very much in advance

Luke

use full path, for example /usr/bin/php and it should work.

Hi ScIT,
Do you mean it like this
/usr/bin/php wget -O- ‘Mailster 3.2.0 - Cron’ > /dev/null

or like this

/usr/bin/php Mailster 3.2.0 - Cron

Cause, I am being asked by the Mailster support team member to use this URL Mailster 3.2.0 - Cron instead of that full path below, you know.
/home/biobrus/web/biobrusinka.cz/public_html/wp-content/plugins/mailster/cron.php 2b7fff1e83eba2fc16b4e92250308d66 > /dev/null

Can you give me the example how the whole command should look like, please?

Thank you very much

/usr/bin/php /home/biobrus/web/biobrusinka.cz/public_html/wp-content/plugins/mailster/cron.php 2b7fff1e83eba2fc16b4e92250308d66 > /dev/null

should work

Hi,

Yes, this is what works fine as I mentioned in my previous posts but I cannot get the wget, curl or GET commands (Alternative URLs) working with this URL Mailster 3.2.0 - Cron

as per their KB article here How can I setup a cron job? - Mailster Knowledge Base

Can you please tell me if it’s even possible or she’ll I find some external/3rd party solution?

Thank you

/usr/bin/wget https://example.com/wp-admin/admin-ajax.php?action=mailster_cron&secret=9407e3177c89bebdaaffb108f432dcc3
# Or
/usr/bin/curl https://example.com/wp-admin/admin-ajax.php?action=mailster_cron&secret=9407e3177c89bebdaaffb108f432dcc3

1 Like

Hi eris,

thanks, but this doesn’t work either! They want me to use this precise URL for some reason:
https://www.biobrusinka.cz/mailster/2b7fff1e83eba2fc16b4e92250308d66

I am just wondering why only this php option works fine but not the others?
php /home/biobrus/web/biobrusinka.cz/public_html/wp-content/plugins/mailster/cron.php 2b7fff1e83eba2fc16b4e92250308d66 > /dev/null

Any idea?

/usr/bin/wget https://www.biobrusinka.cz/mailster/2b7fff1e83eba2fc16b4e92250308d66 > /dev/null

Works just fine

Do you think it might be just something related to WordPress or even the Mailster plugin? Because, it’s still not working for me as you can see on the printsreen below:

Here is the result when I run it from the terminal:

/# /usr/bin/wget Mailster 3.2.1 - Cron > /dev/null
–2022-09-26 11:46:00-- Mailster 3.2.1 - Cron
Resolving www.biobrusinka.cz (www.biobrusinka.cz)… 207.180.245.223
Connecting to www.biobrusinka.cz (www.biobrusinka.cz)|207.180.245.223|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [text/html]
Saving to: ‘2b7fff1e83eba2fc16b4e92250308d66’

2b7fff1e83eba2fc16b4e92250308d66 [ <=> ] 3.95K --.-KB/s in 0s

2022-09-26 11:46:00 (16.9 MB/s) - ‘2b7fff1e83eba2fc16b4e92250308d66’ saved [4041]

Thanks a lot for helping me figure this out. I really appreciate.

Alright, it looks like I got this working only under my admin user CRON jobs, but I still cannot figure out why it doesn’t work under the other user’s profile when I set this up in their CRON jobs. Do you happen to know what might be blocking it from running the wget commands?

Thank you