Whitescreen after purging CGI cache

I have FastCGI cache enabled on several websites.
It always worked fine but I noticed that on 1 website, when I purge the cache in the Hestia control panel (in the website details with the purge nginx cache button), then I get a white screen and I cannot see the website anymore.
In the error log I get:

2022/12/05 11:52:33 [crit] 697658#697658: *174 mkdir() “/var/cache/nginx/micro/xxxxxx/5” failed (2: No such file or directory) while reading upstream, client: x.x.x.x, server: xxxxxx, request: “GET / HTTP/2.0”, upstream: “fastcgi://unix:/run/php/php8.0-fpm-xxxxx.sock:”, host: “xxxxx”

(I removed the sitename and ip address with X).

When I restart the nginx service, it works again.

I already disabled FastCGI cache and enabled it again, then doing the same test but the problem remains.

Any idea?
I don’t have this problem with the other websites on the same server.

When I purge the cache, the website directory in var/cache/nginx/micro is removed.
When I then go to the website in the browser, I get the whitescreen. So it seems that the directory is not created automatically.
When I restart the service, the directory is created with “www-data root” ownership while the other websites have “www-data www-data” ownership.

The other websites recreate the directory automatically when the cache is purged with “www-data www-data” ownership.

That one website does something wrong in the creation probably because ownership is “www-data root”

How can I solve this?

Know issue it will be fixed in the next version 1.6.12 this should come this week

1 Like

Thnx for the swift reply

What’s the strategy?
find dirs > tmp
rm -Rf *
For line in tmp
mkdir -p $dir

rm -fr /dir/*