WHMCS auto-login is not working!

When anyone clicks login to the control panel, it’s automatically logged in! But this is not working in Hestiacp. How can I fix it?

I tried to disable CSRF, but nothing happened!
Thank you.



Screenshot 2022-07-07 180555

did you read this :

Hesita doesn’t support it.

We require extra headers being set that can’t be done via WHMCS

Hi @nada
Thanks for your reply.
But your first link is not working. It said Page Not Found.

https://docs.hestiacp.com/admin_docs/api.html

WHCMS plugin is working how ever auto login not and will currently never work unless we add support for it…

Hi @eris
Thank you for your reply. Hestia requires extra headers, and it’s okay. But What can I do? I’m using Vestacp’s WHMCS module. Do I need to add any PHP code to that file?

We would need to add support for it, but we don’t have any priority for that. Would probaly be an idea to disable the auto login function.

Hi @ScIT

Did you suggest I do this!!!?

I thought you had priority for this! I guess it caused many people to move out to another cp. In the WHMCS forum, I read some topics
something like this!

Yes I do, because we don’t have ressources to work on it. If you like, you can sponsor it or implement it on your own.

At some time, a own hestia/whmcs integration will follow, but this is not on a big priority, there are other projects like ipv6 and rewrite the interface.

That’s ok, we do not provide hestia to get as much users as possible. We use it for our own infrastructure and provide it as it is - without warranty or support.

1 Like