Wordpress permissions and tmp folder problems

Hello.

I’ve been using VestaCP for almost 4 years but now it’s time to move to a new server and new WCP (web control panel). I’ve 4 Wordpress websites I need to migrate.

Now with HestiaCP I always get two problems, even with fresh Wordpress installations.

1 - Unable to install/delete plugins and themes

This can be solved by giving apache permissions to the website:

chown -R www-data:www-data /home/user/web/website.com/public_html

2 - Unable to upload media (Wordpress can’t use the temporary folder)

To solve this I have to:

chmod 777 /home/user/tmp

I don’t remember having these problems with VestaCP on Centos 7, but now I have them with HestiaCP on Debian 10. What am I doing wrong?

Thanks for your work. HestiaCP and CyberPanel are my favorites open-source WCP.

Hello @LITUATUI and welcome to Hestiacp.

What you are describing is not a expected behavior, WP should work fine right after install. My guess something isn’t configured right in apache2 on debian10, maybe a ruid2 problem.

We will have to reproduce this on our side but we need more info from you, like instaled version and steps taken

Hestia doesnt support Deb10 with the current version 1.0.6, this will follow with 1.1.0 which should be released in a few days. As @Lupu already wrote, this sounds like a configuration issue, maybe based on the unsupported os version, if you used the release branch installer. But to identify your problem, we need for sure more informations :).

Thanks for the fast replies guys.

I’m aware that stable version doesn’t support Debian 10 yet.

I’m installing Hestia “beta” on a fresh Hetzner CX21 VPS (4 GB RAM, 2 VCPU and 40 GB NVMe disk) with Debian 10.

After building the VPS I just run the following commands as root.

apt update
apt upgrade
wget https://raw.githubusercontent.com/hestiacp/hestiacp/master/install/hst-install-debian.sh
bash hst-install-debian.sh -v no -k no -z no -c no -t no

I’ve a cousin also with a fresh CX21 Hetzner VPS with the same issue.

Maybe I should try the stable version on Debian 9.

Thats what I thougt, you can’t just use the master script, you need also to have the current deb package, please checkout this way to install on deb10: Release data for version Ver 1.1

Thanks a lot. It worked!

It also solved the ssh-copy-id issue (mkdir: cannot create directory ‘.ssh’: Permission denied) described here: HestiaCP permissions issue


Not very important, but just a suggestion. CyberPanel allows to add ssh keys and change ssh port in the web interface. It might be a good idea to implement, since most newbies don’t know how important these things are to make the server more secure.

Or just an editor in the web interface for the sshd_config file to quickly change the ssh port, disable root login and password authentication.

Anyway, I’m very happy with HestiaCP working on Debian 10. Thanks again!

2 Likes