Wp smush pro - nginx + phpfpm

I have Nginx + phpfpm , i dont install apache…

i need put this code, but , when i put, nothing happend

BEGIN SMUSH-WEBP

location ~* "wp-content/(uploads/)(..(?:png|jpe?g))" {
add_header Vary Accept;
set $image_path $2;
if (-f “/home/mydiretory/web/mydomain/public_html/wp-content/smush-webp/disable_smush_webp”) {
break;
}
if ($http_accept !~
“webp”) {
break;
}
expires max;
try_files /wp-content/smush-webp/$image_path.webp $uri =404;
}

END SMUSH-WEBP

the wp smush pro to not recognize…
ive try create a new wordpress template…put de code and nothing happend too…

gd

GD Support => enabled
GD headers Version => 2.2.5
GD library Version => 2.2.5
FreeType Support => enabled
FreeType Linkage => with freetype
GIF Read Support => enabled
GIF Create Support => enabled
JPEG Support => enabled
PNG Support => enabled
WBMP Support => enabled
XPM Support => enabled
XBM Support => enabled
WebP Support => enabled
BMP Support => enabled
TGA Read Support => enabled

someone know how do i install ?
so thank you…

First remove the image out off:

ive created a wordpress-webp.tpl
ive try remove this code and put the code of wp smush pro, continue…no reconigzing…
what im doing wrong…

There are two templates, one finished in .tpl (http) and one finished in .stpl (https). You must modify both of them.

If you have created a new template, you must select it in the web configuration in hestiacp.

when i remove this code

location / {
try_files $uri $uri/ /index.php?$args;
location ~* ^.+.(ogg|ogv|svg|svgz|swf|eot|otf|woff|woff2|mov|mp3|mp4|webm|flv|ttf|rss|atom|jpg|gif|ico|bmp|mid|midi|wav|rtf|css|js|jar)$ {
expires 30d;
fastcgi_hide_header “Set-Cookie”;
}

nginx fail…

im tryin this…

BEGIN SMUSH-WEBP

location ~* "wp-content/(uploads/)(..(?:png|jpe?g))" {
add_header Vary Accept;
set $image_path $2;
if (-f “/home/mydiretory/web/mysite/public_html/wp-content/smush-webp/disable_smush_webp”) {
break;
}
if ($http_accept !~
“webp”) {
break;
}
expires max;
try_files /wp-content/smush-webp/$image_path.webp $uri =404;
}

END SMUSH-WEBP

location / {
try_files $uri $uri/ /index.php?$args;
location ~* ^.+.(ogg|ogv|svg|svgz|swf|eot|otf|woff|woff2|mov|mp3|mp4|webm|flv|ttf|rss|atom|jpg|jpeg|gif|png|webp|ico|bmp|mid|midi|wav|rtf|css|js|jar)$ {
expires 30d;
fastcgi_hide_header “Set-Cookie”;
}

but on wordpress do not recognizing