Wrong URL with cyrillic letters after migrate from Vesta

I migrated from last VestaCP to Hestia manually: added new user with the same name, made initial settings, transferred files with rsync and made mysqldump on the old vps that uploaded into mysql later.

I have o couple of tags in my CMS with russian letters. And now I got some URLs like “?tag=�_а�_о�_�_”

My old SQL base was encoded in UTF-8 and i found out all my tables in new is in utf8mb3. Is it matter?
How to solve bad URLs?

Create new database via

v-add-database USER DATABASE DBUSER DBPASS mysql localhost “encoding you need”

No, it is not. When I created db I already chose UTF 8.
Anyway, my question is how to fix that wrong cyrillic URLs?

To fix your issue, you probaly need to create a database with the same encoding as @eris suggested above. I dont know if it is possible, to fix the cyrillic symbols in the current db.

My DB was in UTF-8, and I created new in UTF-8 (at least by the panel opinion). As you know, in newer version of MariaDB I can not use old UTF8, now it calls utf8mb3 and it is actually the same as before, as google says.
So I did my best during migration and don’t know to do more :frowning:

Prehistory: migrated from debian 9 with old vesta to the new VPS with Debian 11, Hestia (apache+nginx+php7.0-fpm+mariadb).

I found out that after all migration I can not use a search on my site (online store) if I use cyrillic letters. After typing a request and pressing “search” I’ve got an empty parameter “&search=” in the URL. Cyrillic words just disappears from it.

Please, any help!

Hi everyone, are you ready for the answer?! The problem is…

So, I reinstalled new and clear debian and setted up only apache2+nginx this time, no php-fpm module. And it works, cyrillic URLs are perfect.

Can you please explain, what kink of problem may be in php-fpm, that it provides me such error?