Access Denied: You do not have permission to view this page

I am trying to make a manual WordPress install on my webserver. But after uploading the files to the root directory. when I am trying to access the URL its redirecting to setup (https://domain.com/wp-admin/setup-config.php) which is normal. but showing the following error:

Access Denied
You do not have permission to view this page.
Please check your credentials and try again.
Error Code: 403

2020-08-07 21_31_31-Access Denied

How to fix it?

How did you upload wordpress?

using HestiaCP file manager

Use FTP / SFTP the file manager has some rights issues (Or use the one click installer)

Thank you. I’ll try that. But file manager is the only reason I moved from vestaCP/myVestaCP to HestiaCP. Hopefully, developers will fix this ASAP :innocent:

I made the same. I uploaded wp archive through File Manager. Unarchived it and instal as usual. Everything works fine for me.

1 Like

Please create a issue report where we can reproduce the problem, then we will probaly be able to fix it :slight_smile:: https://github.com/hestiacp/hestiacp/issues/new

There is al ready a issue for it

as @eris mentioned there is already an issue about this.

1 Like

Hi shahadat, first sorry for my english.

This is possibly a permission issue. When you upload the files only push the inside files of your public_html, dont upload this folder.

A solution can be: change the permissions of the public_html folder and its subdirectories and files with filezilla or ssh to 755.
Then change the permissions of the wp-config.php file to 640 or 644.

Good Luck!

Any reason you didn’t use the Hestia built-in wordpress installer?

just don’t. that’s plain wrong for files.

while I undertsand that as motive, I am sorry to say, hestia probably will still be the wrong thing for you.

if you are dependant on things like a file manager and are not able to fix permission issue with your system admin powers, I am afraid you will run into more issues. HestiaCP is no replacement for admin skills and basic linux knowledge, but intended to complement to that by making recurring tasks easier.

don’t get me wrong, I understand everyone needs to start somewhere. however hestia is going into another direction and expects a minimum level of knowledge and ability of handle things yourself. otherwise you are better of with shared hosting or cpanel and the likes.

4 Likes

No special reason actually… I just like it that way.

I understand.
Thank You

Usually i do it this way with WordPress deployment via ssh:

  1. Move all extracted files into public_html folder (/home/your_username/web/your_domain/public_html)
  2. Inside public_html i do this commands:
chown your_username:your_group -R *
  • Chown is not necessary in most cases because it’s predefined by HestiaCP, just to be sure.
find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;
  • These two lines fix all permissions in a few seconds. Fixing them via FTP/SFTP/FTPS can take from minutes to hours (depends on file amount).

Don’t forget to replace your_username, your_domain, your_group with correct values.

1 Like

+1 for using find, that’s the proper way :wink:

3 Likes

Quick note for something new I learned today (and eager to share). WordPress (and other software) usually include the .htaccess file. With the following command we can move all files, including dot files like .htaccess.

(shopt -s dotglob; mv -- * ..)

shopt is a shell builtin command to set and unset (remove) various Bash shell options.

The dotglob shell option if set, Bash includes filenames beginning with a ‘.’ in the results of filename expansion. The filenames ‘.’ and ‘…’ must always be matched explicitly, even if dotglob is set.

2 Likes

that looks dope, thanks for sharing!

File manager directory permission issue fixed: https://github.com/hestiacp/hestiacp/commit/fbb3ed537e59e902416dbc475e87432acb013f7f

2 Likes

8 posts were split to a new topic: Permission settings