Advanced Options page does not open

Hi,

My “Advanced Options” page on web, dns pages etc. does not open. Does anyone know what could be wrong and how to fix it? My problem is connected to this forum topic. Because I assume that modified templates is reffered to on this page!?

And my current version and updates status is as follows (but else everything works just fine):

1.4.14 is an old version I don’t know what O S you are running but you should probally update to the last version

Yes, I have tried, but then I loose every setting on the sites and https stops working with wildcard certificate on them. Upgrading by sudo apt update && sudo apt upgrade and that’s works fine (also by turning on automatic updates in HestaCP works ok). But all certificate settings get’s fucked up.

1.4 is not supported any more and only method to solve the issue is to update.

You can change templates also via command line

v-change-web-domain-tpl user domain template

and v-change-web-domain-proxy-tpl user domain template

Okay, thanks! :star:

Hi, how do a specifically use the v-change-domain-tpl to change apache2 modified template, nginx modified template, phpcgi modified template for a given site?

How are we gonna use the v-change-domain-tpl in details, with examples?

To me, the command seems only to handle templates for complete web site. If so, how are we gonna tell how to change …nginx/default_new.stpl, nginx/default_new.tpl, apache2/default_new.stpl, apache2_new.tpl etc. to be used by HestiaCP with this cli command?

Apache2: v-change-web-domain-tpl
Nginx: v-change-web-domain-proxy-tpl
PHP: v-change-web-domain-backend-tpl

https://docs.hestiacp.com/admin_docs/web.html#id1

Make sure to use the current folder you can’t specify sub folders:

Nginx: /usr/local/hestia/data/templates/web/nginx/
Apache2: /usr/local/hestia/data/templates/web/apache2/php-fpm/
PHP-FPM: /usr/local/hestia/data/templates/web/php-fpm/

For PHP-FPM make sure to match the naming according the docs:

Shall the cli commands be run as hestiacp admin?
I get permission errors:
/usr/local/hestia/func/main.sh: line 1539: /usr/local/hestia/conf/hestia.conf: Permission denied
Error: invalid template format :: /usr/local/hestia/data/templates/web/apache2/default_new.tpl
/usr/local/hestia/func/main.sh: line 100: /usr/local/hestia/log/error.log: Permission denied

And I still cannot open “Advanced Options” in HestiaCP GUI, even if I now have updated to:

Run as root

For the GUI:
Check if there are any javascript errors.

No javascript errrors in browser (F12).

When I do sudo v-change-web-domain-tpl etc. the command is unknown. When I run the command as admin directly it’s available.

Run full command then:

/usr/local/hestia/bin/v-change-web-doman-tpl

Try if you can replicate the issue on the demo.

https://demo.hestiacp.com:8083/list/user/

We have +30k installs running at the moment and you are the first one to report the issue

Hi,

It’s most problably a bug in HestiaCP koncerning the “Advanced Options” page.

For ex. on the web configuration page:

  • When entering the web configuration for the 1st time, toggling the “Advanced Options” does not work

  • Then the advanced options is only start working when you first press “show certificates”. After that toggling the “Advanced Options” works fine, even if you have “show certificates” in different states.

  • I you only have checked “Enable Automatic HTTPS redirection”, you don’t have link to “show certificates” (as in my case). Therefore you cannot get the “Advanced Options” button to start working. You have to temporarily check som of the other checkboxes, for ex. “Use Let’s Encrrypt to obtain certificate”, to get it to start working.

Does not work from start depending on initial settings in the web config page

Clicking “Show certificates” link makes the “Advanced options” start working

If only the option “Enable Automatic HTTPS redirection” is checked, there is no “show certificates” link.
checked-only-enable-automatic-https-redirection

For me the “Show certificates” link is missing (see why above)
show-certificate-link-is-missing

I am not able to replicate the bug on Safari or Chrome…

I have Microsoft Edge. I updated my browser now, and now its working fine. Thanks! :star: