All my Sites Down & Cant access HestiaCP panel

I see some posts, but no real clear answer to what happened to my VPS.

Sites were working this morning but i could not access hestiacp panel. So i thought ill just reboot VPS. now everything is down. I can get in with Putty, but i don’t know what i need to do to correct issue.
I cant even restart nginx
I’m running ubuntu 20.4 with nginx. i get following errors.

$systemctl restart nginx
unable to resolve host hestiacp.domainname.com: Temporary failure in name resolution

i get same result for $apt update

what can i do to correct and get my sites back up and running.

Please…urgent. Thanks

Please check: HestiaCP very Slow - DNS errors - SSL errors - Hetzner - #20 by Aporie

are you suggesting this is the solution? just run that command?
Is my issue a result of the recent update?

Result is that I needed to allow established connections to continue in iptables:

sudo iptables -A INPUT -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT

Currently, yes. We are still investigating, what’s the source of this specific issue. Are you on digital ocean?

I am with Contabo

[email protected]:/$ sudo iptables -A INPUT -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT

sudo: unable to resolve host hestiacp.domainname.com: Temporary failure in name resolution

thats what happened when i ran that command.

Can you login as root and run it there without sudo?

unfortunately I have root login disabled in sshd_config (as everyone seems to recomend)

and its seems i cant use any sudo commands right now so i cant edit that file to allow root login.

Depends on the point of view :slight_smile:.

Do you have a webshell/kvm console to login as root without ssh? When yes, try it over there.

ok…i got into root. Sorry. took a bit. websites are up. Pressure off.
im back into everything.

is that a permanent fix. Do i need to run update or upgrade?

thanks for quick replies. really appreciate that

So have you figured out what is going on?

Can you give instructions for newbies who are afraid that our vps will explode irreparably?

Is that command out there exposed?

I also have to access via “sudo su” to elevate permissions to ‘root’ because OVH directly has root access disabled.

To sum up. Tell me if by doing this I won’t kill any kittens (I’m afraid of losing data):

-I access Putty
-I login
-I get root user
-I paste the code:

sudo iptables -A INPUT -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT

…and there is a high probability that my soul will have peace again?

Due to current testings, it will not survive a reboot - we’re currently looking what caused this issues under the following issue report: [BUG] Issues with Iptables · Issue #1849 · hestiacp/hestiacp · GitHub

The command is save to run, nothing will explode or get lost…

[email protected]:/# iptables -A INPUT -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
[email protected]:/# systemctl restart nginx

Thats what I ran as root user. don’t forget nginx restart.

BUT:

I am having an issue in my magento stores with product not showing up. They are there because the can be accessed individually, but not when i want to see the whole ‘catalog’ of products. How can these issues be related? i assume they must be somehow. I have deleted all caches and reindexed and still no products.

Anyone have a bright idea how this could be linked and resolved?

…well… in my case, nothing seems to have changed… I still haven’t solved the problem.

Did I do it wrong?

Did you restarted nginx?

not before, but I’ve done it now and… still the same

it’s bad idea reboot all vps??

Its a better idea to check your weblog, because it doesnt look like a related issue to the Story above. Have a look at /home/user/web/domain/logs

Screenshot 2021-05-27 165903

I think I read in another post. when i am upgrading after this new Hestiacp version, . was it recommended to keep current-installed? (the N option)

i found the answer:

Regarding the magento products not showing up occuring at this time also. It was an unrelated issue somewhat.
the elasticsearch had to be restarted

check status if you are having same issue.

systemctl status elasticsearch