Both and URLs no longer working

My server is running HestiaCP 1.1.1 and today I find none of the URLs for webmail is working (/webmail URL gives me the 404 error while URL gives me a default SUCCESS page). I checked the Mail Server Config section and see that there is the webmail alias:

I dug out this old post and tried the few things there - none worked.

The webmail alias is obsolete, please use webmail.domain.tld. You can also add mail ssl to get valid ssl certificates for the webmail and exim4/dovecot services (you need to use mail.domain.tld).

Good news - adding Lets Encrypt SSL to the MAIL domain makes the working for accessing the roundcube - so it looks like a security feature.

The URL still gives the 404 error.

1 Like

OK, thanks for telling me this!

webmail.domain.tld will also work without mail ssl, just as additional note :).

Well, not in my case. I can access the URL but it shows only the SUCCESS page, not the RoundCube login frontpage. The only thing I can get it work on my server is to issue SSL to a certain mail domain.

well… a quick and absolutely dirty fix suggestion… you could create on “yourdomain.tld” a folder called “webmail”, containing an index.html in which you just write <script type ="text/javascript>document.location=“webmail.yourdomain.tld”

that should do the job :slight_smile:
ps: replace yourdomain.tld with the actual domain you have got