Without access to RoundCube on webmail.domain.tld

There is a “webmail” DNS A record pointing to my VPS IP, but when I go into webmail.domain.tld, i get the following message:

webmail.domain.tld

And if I create a web domain to enable SSL for webmail:

ssl.webmail.domain.tld

I’m sorry, but this is way to less informations. You didnt shared your os, version, what exactly your steps where to enable webmail.domain.tld for your mail and what you did to solve or analyze the issue on your own - for example checking the (access) logs, verify if the ip is correct, a certificate has been created for your domain and so on.

Also I strongly do not suggest to share any ip’s or dns names in our fourm or github project.

As @ScIT mentioned, we need more information in order to help you with this.

  1. Which version are you currently running?
  2. Is this an upgraded installation (e.g. 1.0.6 -> 1.1.0)?
  3. What is your webmail alias set to under Server > Configure > Mail Server > Webmail Alias?

Sorry, you’re absolutely right.

I had HestiaCP 1.0.6 installed and working on Debian 9 and a few days ago I updated to 1.1.0. Previously it accessed through host.domain.tld/webmail with no problems. Since then I had not tested access to webmail. As the above URL is no longer available, I have tried to enter using webmail.domain.tld and those are the results. I have also tried to enter using the links located in “HestiaCp > Mail > Open webmail icon” next to mail domain and “HestiaCp > Mail > Mail Domain > Open webmail icon” next to mail account. The latter sends me to “http: //host.domain.tld/? [email protected]”. Also from “HestiaCp > Mail > Mail Domain > Mail account > http: /webmail.domain.tld” and they all give the same result: “Successs! Your new web server is ready to use” if I delete the web subdomain and the certificate, and “We’re working on it! This site is currently under construction. Please check back soon.” if i create the web subdomain and the certificate.

DNS A record points to the same IP as other working subdomains. The value of “Webmail alias” in “Server > Configure > Mail Server” is “webmail”.

I create and delete the webmail subdomain from “Web > Add web domain” and “Web > Delete icon”. The DNS record always remains.

I don’t see anything useful in the logs, not even the roundcube.

SMTP and IMAP are working in Thunderbird.

You should not create a web domain for mail unless you’re installing another webmail client, as this is automatically handled by the mail stack routines in Hestia.

The process of configuring mail services/webmail on Hestia is as follows:

  1. Log into the panel.
  2. Click on Mail.
  3. Add the necessary mail domain.
  4. Edit the domain and enable SSL/Let’s Encrypt.

At this point, the domain is added to dovecot/exim and the necessary webmail v-hosts/aliases are created.

What happens if you remove the webmail subdomain you’ve created from Web domains, run v-delete-sys-webmail user domain.tld and v-add-sys-webmail user domain.tld 'yes' (replacing user/domain.tld accordingly)?

1 Like

Great! RoundCube works again.

  1. Deleted the web domain.
  2. “v-delete-sys-webmail user domain.tld” automatically deletes the DNS record.
  3. “v-add-sys-webmail user domain.tld ‘yes’” re-creates the DNS record.

Now all that’s left is to add a LE certificate for that subdomain. I have tried “v-add-letsencrypt-host” and “v-update-letsencrypt-ssl” but it is still not valid.

Thank you very much for your help.

Turn off Let’s Encrypt support and re-enable it for the mail domain, you should receive an SSL certificate which is valid for mail.domain.tld and webmail.domain.tld.

1 Like

Now everything works correctly. Thanks again.