Can't log in after install

So i’ve just installed hestiacp and when I try to log in with admin it won’t work. I deleted RKEY and changed the password with v-change-user-password. I tried logging in with all the common browsers. I did not specify a domain since everything is local.

My auth.log is empty and my nginx-error.log is saying the following for every login attempt:

2023/02/13 11:30:58 [error] 1040#0: *78 FastCGI sent in stderr: “PHP message: PHP Warning: session_start(): open(/usr/local/hestia/data/sessions/sess_509rj9h1j5aohni1hm6d6uu9t4, O_RDWR) failed: Permission denied (13) in /usr/local/hestia/web/inc/main.php on line 2PHP message: PHP Warning: session_start(): Failed to read session data: files (path: /usr/local/hestia/data/sessions) in /usr/local/hestia/web/inc/main.php on line 2” while reading response header from upstream, client:, server: _, request: “POST /login/ HTTP/1.1”, upstream: “fastcgi://unix:/var/run/hestia-php.sock:”, host: “”, referrer: “

What are the permissions in /usr/local/hestia/data/sessions/

drwxrwx— 2 root root 4.0K Feb 13 10:50 sessions
or ls -lah in sessions directory:
drwxrwx— 2 root root 4.0K Feb 13 10:50 .
drwxr-xr-x 10 root root 4.0K Feb 13 10:50 …

sessions folder should be admin:admin

drwxrwx— 2 admin admin 2.7M Feb 13 10:30 sessions

Thank you very much. I changed the permissions to that folder and it worked.

For any noob (like me) wondering what I’ve done:
I ran these commands:
/usr/local/hestia/data# chmod 770 ./sessions
/usr/local/hestia/data# sudo chown admin:admin ./sessions

This changed:
drwxrwx— 2 root root 4.0K Feb 13 10:50 sessions
drwxrwx— 2 admin admin 4.0K Feb 13 10:50 sessions

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.