Custom document root not working after being set


I have an issue where the custom document root doesn’t seem to be working even though it is set in the control panel and i still get the “Success your web server is ready”

I’d initially added the document root and there was a typo in the document root so it wouldn’t allow it since the directory didn’t exist. I corrected the the type and it saved successfully but now it’s stuck on the web server page.

I should also add that i delete the web record in the control panel to recreate it and the problem still seems to persist

I’ve tried adding another user and another site, but it’s doing the same on these to, completely ignoring the custom document roo

I have also checked the files here /etc/apache2/conf.d/domains# and these have the correct document root in but it doesn’t seem to be honouring it

Do you have multiple ips assigned to the server

No, just one I.P.

Webserver is ready message is usally an invalid config so nginx or Apache doesn’t load. domain linked to the wrong ip and so on…

What if add the domain with out custom docroot does it work then?

Also some vps providers assigns a internal ip so it might cause the same issues as above

I get the same problem without the custom document root, the 2 sites i added before these are still working with the custom document root which is also weird.

Is there a way to view or reset the config somehow?

Deleting the user and add the web domain results in the same error, as well so at the moment no new users or websites can be added without getting that error

What error do you see?

Sorry i didn’t mean a specific error message, i meant the issue of new user and sites now defaulting to the web server is ready message whilst exisiting sites and user still work

Check if Nginx / apache2 are reloading with

nginx -t and apachectl configtest to make sure the configs are correct.

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok

nginx: configuration file /etc/nginx/nginx.conf test is successful

AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using vps.*********.com. Set the ‘ServerName’ directive globally to suppress this message

Syntax OK

Hello, i’ve resolved the issue, it was basically this problem of the www alias not being there

Make sure you either set the domain up with the www or add it as an alias

Oke and other 2 domain parts “ltd” are a know issue

I currently have this issue on latest HestiaCP. What if i have multiple ips assigned to my server?
Private IP: 172.31.#.#
Public IP: 13.212.#.#

Note: My server is running on AWS EC2 with Ubuntu 22.04

I tried to give www on aliases field but still no luck

Use the Public one…

I have resolved this issue. My mistake was selecting invalid IP address when creating domain. When I change to second option it works. I wonder why IP Address dropdown show same label with different value (IP address)? Can I remove the first option?