Disk quota not applied to mails

Dear All,

Kindly help me understand whether disk quota is applied to mails

This is what i did:

  1. created a package CLIENTS with a disk quota of 1gb

  2. created a standard/web account with the domain, abc.com with mails enabled

  3. logged in as abc.com user

  4. Tried creating mail ids with 10 gb quota and it accepts.

My worry here is that the domain abc.com has a package CLIENTS with a disk quota of 1 gb.
Whereas, abc.com user is able to create mail ids even with 10gb, which should NOT be allowed.
How to prevent this so that the user is NOT able to create mail ids which do NOT exceed his allowed disk quota of 1 gb ?

Thanks in advance.

Unless file quotas are installed during setup the package limits are not “enforced”

Hello @eris,

Thanks for the reply

Can i install the file quotas in the existing installation?
If done, will be user be restricted from creating mail ids exceeding the disk quota as set in the package?

If it cannot be done in an existing installation, kindly let me know how to include/install FILE QUOTAS in the fresh installation.
Below is what I did in the last installation. Please let me know how to include FILE QUOTAS in the below

sudo bash hst-install.sh --port ‘8083’ --lang ‘en’ --hostname ‘host.abc.com’ --email ‘[email protected]’ --password ‘passwd’ --apache yes --phpfpm yes --multiphp yes --vsftpd no --proftpd yes --named yes --mariadb yes --mysql8 no --postgresql no --exim yes --dovecot yes --sieve yes --clamav yes --spamassassin yes --iptables yes --fail2ban yes --quota yes --api yes --interactive yes --force

Thanks in advance

In you command quotas are enabled already:

–quota yes

Hello @eris,

Thanks for the reply
But, it is not ENFORCED as i explained in my first post.

I am running VPS with Debian 12
Kindly help

Thanks in advance

Can you create try to upload a file of 2 gb and upload it to server via ftp and check if it works?

Hello @eris,

Thanks for the reply
This is what i did:

  1. changed the disk quota of CLIENTS package to 2 Mb

  2. applied the CLIENTS package to abc user

  3. logged as user abc

  4. Tried uploading a file of 5mb.
    The file got uploaded but showing a size of 1.9mb (probably truncated OR incomplete/corrupted just to ENFORCE file quota

  5. But as abc user, i am still able to create mulitple mail ids with 10gb quota or more and it accepts.
    I wanted to check whether i am able to send mail, but webmail rejects login saying LOGIN FAILED.
    tail -n 100 /var/log/roundcube/errors.log
    tail: cannot open ‘/var/log/roundcube/errors.log’ for reading: No such file or directory

I need your help in troubleshooting roundcube login issue in another thread so that not to go offtrack the present discussion

  1. Based on the above, I could see:
    a. disk quota is partially enforced for ftp uploads (PARTIALLY in the sense, the bigger file gets uploaded but gets truncated to a smaller size to ENFORCE disk quota)
    b. disk quota is not getting ENFORCED for the mail accounts.

Kindly help.
Thanks in advance

Roundcube itself is not include the quota calculations. As it doesn’t store its data in the /hom/user dir only after you have send the email.