Domains doesn't work

Hello together

I have been using Hestia since August this year and so far everything has been working without any problems. But today I updated from version 1.8.8 to 1.8.10 and since then all domains of my created user do not work anymore or show only the “success” page. In the address bar the URL is replaced with the IP of my server.

The URL for Hestia, on the other hand, works without problems and it can’t be due to the DNS zones, since I use Cloudflare.

Maybe one of you can give me a hint what the problem is.

Thank you very much.

Check /etc/apache2/apache2.conf is the same as

I forgot to mention that I do not use apache2. I use nginx exclusively. I have already compared the hestia nginx.conf with the one under /etc/nginx. They are identical. The nginx.conf files for each domain also look fine to me.

I also noticed that I am being redirected to /var/www/html/index.hmtl. Which yes would mean that the domain nginx.conf files are not being used.

Hi eris

I have a similar problem. After the update I get a 500 Internal Server Error on all web pages. In the Apache error log I see the following error: /.htaccess: <IfModule not allowed here. Apache2 config is OK.

Can you DM me your domain?

We haven’t changed nginx or apache2 config

This is strange, before the update everything is working. On a webpage without PHP, set the Proxy Template to suspended fix the problem, but not my Wordpress Websites.

What are exactly the error logs?

I have just run the v-rebuild-all user command via the cli. I received the following messages

cat: /usr/local/hestia/data/templates/web/nginx/wordpress.tpl: no such file or directory
cat: /usr/local/hestia/data/templates/web/nginx/wordpress.stpl: No such file or directory
cat: /usr/local/hestia/data/templates/web/nginx/owncloud.tpl: No such file or directory
cat: /usr/local/hestia/data/templates/web/nginx/owncloud.stpl: No such file or directory

I have the same problem, one of the domains stopped working, another one with the same parameters still works. I have HestiaCP 1.8.8. I can send my domains via DM to you if you want

I see only this error in the apache error log:
[Tue Oct 24 20:04:57.705184 2023] [core:alert] [pid 63509:tid 140576620013248] [client x.x.x.x:0] /.htaccess: <IfModule not allowed here

My web pages are now working again, except for the webmail URL.

For this I have done the following:
I copied the templates for Owncloud and Wordpress (which I use) from /usr/local/hestia/data/templates/web/nginx/php-fpm to /usr/local/hestia/data/templates/web/nginx.

After that my web pages were running again. However, I also adjusted the nginx.conf several times and set it back to default.

But I strongly assume that it is because of the templates. Otherwise the v-rebuild-all command would not output the message written above.

In that case check your server config it can’t right …

It looks like it is running in proxy mode even it is not configured like that …

At the moment all web pages work again and I have nothing changed, really strange. I restarted the server and everything is still running. I hope it stays like this now.

One of the domains still doesn’t work for me. Which log should I check and analyze? Please help




there is nothing here that could seem interesting

[Tue Oct 24 18:50:16.890508 2023] [proxy_fcgi:error] [pid 2590769:tid 139693207320320] [client] AH01071: Got error 'Primary script unknown'

the above log comes from

after pasting - the page appears:

and - the mail server client page is displayed correctly.

The name1 entry is configured the same way as name2 in the A record of the DNS settings for

everything was fine. Nobody changed anything - it’s a mystery to me

could this be the cause? since I connect to from different IP addresses and only 1 IP address had an error for unknown reasons, and other IP addresses were not on the .log list?

there are 2 DNS entries pointing to the same page (IP address) one entry works, the other does not - it does not seem that this could be the cause of the error

Also getting this on one Hestia server. Down on all domains since the upgrade at 5am this morning. Other servers seem OK so far. Invstigating.
Same error about .htaccess and <IFmodule. Even after I’ve removed .htaccess !
Have tried restarting server, rebuild domains, replace apache2.conf with github version.