Enable sftp connection

Hello my name is Noé from Spain, and i have a question. Sorry for my spanglish…
I have installed hestiacp in one server and i need to enable SFTP connection. But i find in DOCS and internet tutorials but it does’t work.

Maximum i enable FTP with TLS/SSL, but i like to enable SFTP access.
Can you help me?

thanks a lot

SFTP should be enabled by default unless you have modified the /etc/ssh/sshd_config file.

not. I can’t change anything and it doesn’t work with any user, including admin…
Port is 22, sure??

@nomopo well, if can connect to SSH, you can connect to SFTP as well unless you change something like @ScIT wrote. Please do the effort to google for this kind of basic questions :

Google “sftp connection” : https://www.google.com/search?q=sftp+connection&oq=sftp+connect&aqs=chrome.0.0i457j69i57j0i20i263j0l2j69i61j69i60l2.6292j0j7&sourceid=chrome&ie=UTF-8

Second result, it explain what is SFTP : https://www.digitalocean.com/community/tutorials/how-to-use-sftp-to-securely-transfer-files-with-a-remote-server

Conclusion : you don’t have to enable anything, just connect your SFTP client using SSH credentials

If i do this with root user i can login, but with HestiaCP users doesn’t work. I think i need to add to group users but i don’t know how…
Please can you help me??
thanks a lot

Look at the solution here please : Default SSH access is removed?

Sorry but in one server it works fine when i modify sshd_config and put 0.0.0.0. for all connections. But in other it doesn’t work, same distro ubuntu 20,04…

I’m going to burn all !!!

Now i can do this with admin user, but i create another user XXXX and XXXX can’t access to sftp.

Thanks right… Thanks everybody. Problem is that file sshd_config is not configured…

thanks a lot

@nomopo Please dont push your request in a 2 month old thread, when you got already a own one. Please proceed with your request here.

ok sorry for this…

Sorry but in one server it works fine when i modify sshd_config and put 0.0.0.0. for all connections. But in other it doesn’t work, same distro ubuntu 20,04…

I’m going to burn all !!!

Now i can do this with admin user, but i create another user XXXX and XXXX can’t access to sftp.

hestia sets up sftp access automatically for all user. unless you change something in your sshd_config manually it should work out of the box.

so, the question is which part are we missing, that you changed in your sshd_config before or after you installed hestia and which is now preventing you from using sftp correctly :man_shrugging:t2:

2 Likes

for all user in my server not. I install hestiacp with default options and i have 1 user Admin, with this user i can connect to sftp, but if i create another user, for example PEPE, with PEPE i can’t connect. I think that i need to give permissions or add a group user, but i don’t know what. I install hestiacp in 2 servers with ubuntu 20.04 and i have same problem.
I’m sure that the problems is me, that i need to do anything what i don’t know what and in “internet” i don’t find any solution.

Allways said me this:
Permission denied, please try again.
And user and password are right.

Aggg problem is keyboard… I use spanish keyboard and server have installer default en_EN. I change dpkg-reconfigure locales with es_ES and it works fine.

THANKS A LOT TO EVERYBODY… i love this!!! and You!!!

First step is to check you error log

/var/log/auth.log

Probally you will see something like pam_unix(sshd:auth): authentication failure