Error 500 when log in as user (not admin)

Hi!
If I log in to the control panel as user not admin, I get a 500 error. If I log in as admin first and click on the “log in as user” icon
then everything is ok.
after installation, I changed the sys port (v-change-sys-port 10) and added letsencrypt (v-addletsencrypt-host)
I did not find anything useful in the logs - maybe I looked in the wrong place?
Thank you!

Issue: https://github.com/hestiacp/hestiacp/issues/581

You can check the hestia own nginx logs in /usr/local/hestia/log/nginx-error.log. Also I suggest to reset the backend port to 8083 an check if the issue occurs again, if not, please choose a different port in a higher range.

The first thing I tried was to change the port back :slight_smile:

2019/09/05 22:56:41 [error] 1081#0: *22 FastCGI sent in stderr: "PHP message: PHP Warning: Invalid argument supplied for foreach() in /usr/local/hestia/web/login/index.php on line 154" while reading response header from upstream, client: XXX.XXX.XXX.XXX, server: _, request: "POST /login/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/hestia-php.sock:", host: "my.hestia.net:8083", referrer: "https://my.hestia.net:8083/login/"

Can you post the output of:

v-list-sys-config json

{
    "config": {
        "WEB_SYSTEM": "apache2",
        "WEB_RGROUPS": "www-data",
        "WEB_PORT": "8080",
        "WEB_SSL": "mod_ssl",
        "WEB_SSL_PORT": "8443",
        "WEB_BACKEND": "",
        "PROXY_SYSTEM": "nginx",
        "PROXY_PORT": "80",
        "PROXY_SSL_PORT": "443",
        "FTP_SYSTEM": "vsftpd",
        "MAIL_SYSTEM": "exim4",
        "IMAP_SYSTEM": "dovecot",
        "ANTIVIRUS_SYSTEM": "clamav-daemon",
        "ANTISPAM_SYSTEM": "spamassassin",
        "DB_SYSTEM": "mysql",
        "DNS_SYSTEM": "bind9",
        "DNS_CLUSTER": "",
        "STATS_SYSTEM": "awstats",
        "BACKUP_SYSTEM": "local",
        "CRON_SYSTEM": "cron",
        "DISK_QUOTA": "yes",
        "FIREWALL_SYSTEM": "iptables",
        "FIREWALL_EXTENSION": "fail2ban",
        "REPOSITORY": "",
        "VERSION": "1.0.5",
        "RELEASE_BRANCH": "release",
        "LANGUAGE": "en",
        "BACKUP_GZIP": "",
        "BACKUP": "",
        "WEBMAIL_ALIAS": "webmail",
        "DB_PMA_URL": "",
        "DB_PGA_URL": "",
        "SOFTACULOUS": ""
    }
}

Almost a month has passed. Free support cannot help I guess… Is there any paid support? Is there any hope of fixing this bug?

We could not reproduce this issue on our side. We use different systems for testing, proxmox and hetzner cloud service for example - all is working well.

Can you check if the issue exists in different browsers and also if you use the incognito mode?

I have already tried different browsers and incognito mode - 500.
I have already tried admin.domain.com:port and user.domain.com:port - the same sh!t.
Maybe there are wrong permissions somewhere…

# ls -la /usr/local/hestia/data/sessions/
total 20
drwxrwx--- 2 admin admin 4096 Oct  2 13:31 .
drwxr-xr-x 9 root  root  4096 Sep  4 23:01 ..
-rw------- 1 admin admin 1130 Oct  2 13:31 sess_3lof7qr72jl2ok2suomoke
-rw------- 1 admin admin 1130 Oct  2 13:31 sess_tpro9kuh8qaftj7o7v1964
-rw------- 1 admin admin   38 Oct  2 13:31 sess_uk1dg2h1lql28qh2rigo07

I deleted the main web domain, added again. I don’t know what else to try.
To be honest, it doesn’t bother me too much, but this is a bug and it needs to be found and fixed, I suppose. In general, the product is very interesting. Especially in terms of mail domains supporting Letsencrypt certificates.

It may be a bug, yes: But as I already wrote - we do not have any other reports about this issue nor we have found them on our own test or productive systems.

I can suggest you to try the install on another vps and check, if the bug is still persistent. Hestia works out of the box, on a lot of vps provider and virtualization or physical systems we’ve tested and also have in productive use.

All you can offer me is server re-installation? Really? :slight_smile:
This server is in production mode and I noticed this minor bug too late.
I don`t want to migrate 20gb of mailboxes again.
Solving problems with some software by reinstalling the entire server from scratch - hmm… this is not my way.
Anyway, thank you.

Hello @vitich I think you misunderstood SciT, there is no need to reinstall your production server.

It would be very helpful if you can reproduce this problem on a different vps (testing) and document your process so that we have a better chance to reproduce this on our side too.

(I skimmed trough the thread and didn’t found any info abour cur current enviorment: hosting, os, kvm, lxc, baremetal etc. )

1 Like

This server is on hetzner cloud

Since you use Hetzner it’s really easy to get a new VPS for a couple of days and set it up the same way with the one that you’re having issues with. Make sure you document/take notes of every command you input, along with the output.

Take a look here for an example of detailed logging. That thread is also a perfect example of how fast problems can be solved, when the developers have all the info about how the VPS was set-up. @ScIT spotted my mistake almost instantly! Without detailed logging, It might have taken him days or months to find out what I did wrong.

2 Likes

Thanks for the offer, but I won’t do it. Sorry. I migrated the mail server to the customer and absolutely do not want to spend my time and my money. The mail server is working - thank you. The only thing that may help you to find the bug in the future is that the server had 2 addresses (floating ip). I forgot to tell you about it. After installing the panel, one address was deleted.