Error message: 500 Internal Server Error

After activating SSL for the domain name I face with 500 Internal Server Error when I try to go to domain. The message is below:

"# Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [email protected][mydomain].com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

Can someone please help me?

Does it work when you deactivate SSL??

Please add this piece of information too :sun_with_face:

Check /var/log/hestia/ngixn-error.log

or /var/log/apache2/domains/
or /var/log/nginx/domains/

without SSL I CANNOT setup Wordpress so idk what to do. This is what the page looks like when SSL is deactivated

I have looked for both of them on the Files search option, nothing came out

It’s clear you have SSL reissue problem! Meaning, you have to wait for that particular domain name to issue your SSL certificate once again…!

You have 3 choices no more to do, either use another domain name to issue your current SSL and therefore your site will be up.

or, use same domain but another SSL issue source.

or, the is the less hassle choice, wait until your SSL certificate runs out which is maximum 1 month to redo same operation over again.

Personally, I’d go with choice 2 and then 1 to have my site up and running asap. But it’s your choice!

Good luck m80

1 Like

Or clear the HSTS database/records in your browser

but it does the same exact issue for all the other domain names(like 6 others). My SSL issuer is CloudFlare, and the interesting thing about what’s going on is that once we host the domain name on my brother’s Hestia and use the same CloudFlare it works on his Hestia.

Hmmmmm, I’d still say it’s an SSL problem but then it could be the installation for your control panel :bulb:

How many times did you issue the same SSL for each domain? You might’ve contaminated them already!

I faced this issue myself and heard it before as well … BUT let’s say you make a subdomain name on Cloudflare and try to install one of your domains and see how you go…! If same problem happens again. Then, try LetsEncrypt issued by HesitaCP and you’re good to go for sure :hand_with_index_finger_and_thumb_crossed:

tried this method didn’t work. still getting the same exact error when i enable the SSL, I even did a domain transfer and tried it again but it gave out the same exact error

I tried all of the methods you’re referring to, none of them worked.

Where did you buy the server?? Can you share what details they sent you??

PS. Cover sensitive parts :eyes:

I use Oracle and I installed Ubuntu on Oracle then HestiaCP to Ubuntu. What details are you requesting?


this method didn’t work, is there any other method that you can help me with?
Why don’t people who have built Hestia CP respond?

well, @eris has responded multiple times. Also you still havent provided any log files as requested here:

An internal server error produces in 99% of the cases a log entry, which leads to the issue. Checking log files is something you should be able to do as sysadmin, when you’re using hestia.

@jvhestia If it was SSlL issue I would’ve helped you in no time to resolve it but it is clear that you have Hestia installation configuration issue.

For that reason I asked your server details so admins can help out and realize what were you doing wrong!

PS. NO IPs needed and DNS settings to share for public!

Good luck m8 :wave:

my Hestia was working with no issue, this started to happen mid November somewhere sudden.

I can give you access to both HestiaCP and My server so you can take a look at it?

I cannot find those log files in hestiacp.