Fresh install - phpmyadmin - page not found

Fresh install on Debian 11.2.
HestiaCP: v1.5.7

Install command:
sudo bash hst-install.sh --apache yes --phpfpm yes --multiphp yes --vsftpd yes --proftpd no --named yes --mysql yes --postgresql no --exim yes --dovecot yes --sieve no --clamav no --spamassassin no --iptables no --fail2ban no --quota no --api yes --interactive yes --with-debs no --port 8083 --hostname web.domain.tld --email [email protected] --password **** --lang en

When I go to http://web.domain.tl/phpmyadmin or https://web.domain.tl/phpmyadmin, I get Page not Found.
What did I miss?

Is web.domain.tld added as webdomain under your admin user? Does pma show up on any other domain hosted on that server?

Yes

No

Log: /var/log/hestia

nginx-error.log:
2022/01/27 20:37:06 [error] 492#0: *485 "/usr/local/hestia/web/phpmyadmin/index.php" is not found (2: No such file or directory), client: 192.168.1.201, server: _, request: "GET /phpmyadmin/ HTTP/1.1", host: "web.domain.tld", referrer: "https://web.domain.tld/list/db/"

pma doesnt run under port 8083 or hostname.domain.tld with a proxy pass redirect - it runs under the normal apache2/nginx system. As written, try to use a normal webdomain added to hestia.


/usr/local/hestia/web/phpmyadmin/ does not exist.

Hestia runs under the normal domain

https://domain.com/phpmyadmin/

1 Like

Add yourdomain.tld to a user, set the dns record to it, visit http://yourdomain.tld/phpmyadmin

It looks like you try to access https://web.yourdomain.tld:8083/phpmyadmin…

It looks like you try to access https://web.yourdomain.tld:8083/phpmyadmin…

Nope.

Are you using a template that proxies traffic from https://domain.com to https://domain.com:8083

No.

I on a proxmox server with in between a NGINX proxy for all my services.
Also I am having a other HestiaCP server on Ubuntu 18.04 which works perfectly fine, no issues with PMA.

This log shows, that you try to access it under hestia service, which runs on port 8083. A 404 not found should be logged or reported under /home/admin/web/web.domain.tld/logs/

1 Like

Logs are empty… Pfff… :frowning_face:

Also your access log? If yes, then there is something wrong in your custom setup…

I used your generator to install HestiaCP, no complicated other packages were installled.
Pff… It took me now about 5 hours to figure this out… Frustrated argg!! I quit. I doesn’t work and will not work.

1.5.6 an 1.5.7 did nothing change regarding phpmyadmin or web

1.5.6 Fixend issue with installer + Upgrade script to “fix” an issue with SSL
1.5.7 Fixed the issues apt keys

As all traffic if forwarded to /usr/local/hestia/web/ folder according your logs I suggest checking out what goes wrong…

Custom setups are impossible for us to debug. And unless you are willing to pay for the time I need to invest into it to test I am not able to do so…

1 Like

So in your Nginx proxy you already forward the traffic from http(s)://domain.com to https://domain.com:8083. If it is done with the Hestia or with any nginx proxy it doesn’t matter.

You have to modify some config to get it working how ever it falls out off scope for us…

I have templates for Nginx + Apache2

Or Nginx

Those templates are adjusted to allow phpmyadmin to severed on https://domain.com/phpmyadmin even with proxy

Why I can’t use http://ip/phpmyadmin/

For security reasons we have decided to disable this option.
Database — Hestia Control Panel documentation

Aha… I defined a new location in my proxy to /phpmyadmin.
Solved.

location /phpmyadmin {
…
proxy_pass http://192.168.1.210:80;

Thanks for your help! And sorry for my frustration… :wink:

If you have modified the default template remember that it will be overwritten.