Hestia on Ubuntu 20.04 LTS reboot server and not work

Hestia 1.4.13.

Rebooted the server and it became unavailable from the network, all sites are also not available. IPs are not pinged, the server itself works, the status of hestia and nginx and apache2 - active without errors.

What’s wrong? Where else should I look? The settings in /etc/network/interfaces are correct.

2 Server, reboot 2 servers and 2 not work.

What does ip address show and can you ping out site servers?

No ping.
“What does ip address show”.
Where does it show?

When you enter ip address in command line it will provided the used ip addresses and if it is connected.

No - I can only log in via noVNC directly to the server (at the hosting provider), there are no more servers on the network.

No SSH, no PING - no domains, no IP.

You can still login via noVNC and run the command…

ip address

It will at leas show if you are connected or not …

I have a suspicion, my last operation was: in the IP settings I specified the domain in the “default domain” field for the two IPs on the server.

There are two IPs on the server. The primary and secondary.
The ip address shows a secondary IP, not the primary one :frowning:

I changed the IP in the file /etc/netplan/60-hestia.yaml to the first - “ip address” started showing the first one (but not both, only one of the two shows).

If you have Netplan enabled it should usually see like:

# This file describes the network interfaces available on your system
# For more information, see netplan(5).
  version: 2
  renderer: networkd
      addresses: [ primaryip/24 ]
      gateway4: gatewayip.1
        search: [ com ]  
              - ""
              - ""
              - ""

And then hestia.yaml

# Added by hestia, please do not edit the file manually!
  version: 2
  renderer: networkd
        - extraip/24
        - extraip/24
        - extraip/24

I did not enable anything, I just found why a different IP is displayed, because it is in this file /etc/netplan/60-hestia.yaml was specified, if you specify there the first IP, then the first is displayed everywhere.
And in the file itself -1 IP (and there are 2 on the server)

Also, after the restart, nginx could not start because apache was interfering with it.
I found a fix on the net
In /etc/sysctl.conf
Add line:
net.ipv4.ip_nonlocal_bind = 1

After that all services started running normally, but servers still don’t get up to speed.

Remove 60-hestia.yaml (Create first a backup) and give the server a reboot. If it comeback only the only way to add the second ip is to modify the second ip to /etc/network/interfaces or convert everything over to Netplan

1 Like

Thank you so much!
It worked.
I don’t know why this file appeared and where it came from, but it was interfering with the panel and the server.

I don’t know how Ubuntu works with Netplan vs /etc/network/interfaces are not present…

/etc/network/interfaces is present.
I do not know why and where in netplan files, but this file is in all panels, I now have 14 Hestia on 14 servers.

And the problem is still there now - the panel stopped seeing the second IP. Only the sites on the primary IP work, and the second (which is exactly what was in netplan) does not work.

In the file /etc/network/interfaces 1 basic IP (in all 14 panels, and they work, on all but these two, both IPs work).

How do I get the second IP to come back on where it should be prescribed?

It looks like we need to improve the checks when Ubuntu servers don’t use netplan but use systemd or network interface for the last step we can probably swtich to the “Debian” method…

All 14 servers on Hestia are out of order and not working properly, the problem is exactly in the update 1.4.13.

Until the server is not rebooted, everything seems to work, but gradually increasing problems and after a reboot the panel does not work anymore.

1.4.13 didn’t not change anything regarding ip configuration so it is very strange with this behaviour.

Did you upgrade from 1.4.12?