How to create cron for a user?

I have standard system crons working.

I am trying to run cron for php file in site.
I tried many commands, including those offered on the forum.
For example:
/usr/bin/php7.4 /home/user/web/
sudo /usr/bin/php/home/user/web/domain/public_html/file.php
/usr/bin/curl --silent &>/dev/null

All this is not working.
In the logs I get:
2022-01-22 11:00:54 v-unsuspend-cron-job ‘admin’ ‘12’ ‘no’ [Error 6]
2022-01-22 10:39:47 v-unsuspend-cron-job user’ ‘1’ ‘no’ [Error 6]
2022-01-22 10:39:47 v-unsuspend-cron-job user’ ‘2’ ‘no’ [Error 6]

I did not find any help on this topic from Hestia. How to create a cron for a user?
Any ideas?

/usr/bin/phpx.x /home/{user}/web/{}/public_html/file_to_run.php

Should work

Where phpx.x is the php version you want to use ( or use php for system default) and. {user} is your {user} and {} for domain

Never use sudo in a cron command!

I already tried this scenario. Also his options. I tried again. This does not work.

Any errors / issues / cron reports

v-unsuspend-cronjob error has nothing to do with the cronjob not working. Make sure to turn on the notifications:

Set the time to run ever minute and wait for x min. You should receive a mail if there is any output…

I failed to run cron using the activate method. I tried to install after 1 minute. This does not work. The fact that kroner works I judge by the log.

After every cron activation I get:

2022-01-22 12:40:10 v-unsuspend-cron-job ‘korobok’ ‘2’ ‘no’ [Error 6]
2022-01-22 12:40:56 v-unsuspend-cron-job ‘korobok’ ‘2’ ‘no’ [Error 6]
2022-01-22 13:09:36 v-unsuspend-cron-job ‘korobok’ ‘2’ ‘no’ [Error 6]
2022-01-22 13:10:44 v-unsuspend-cron-job ‘korobok’ ‘2’ ‘no’ [Error 6]
2022-01-22 13:13:10 v-unsuspend-cron-job ‘korobok’ ‘1’ ‘no’ [Error 6]

These are my last attempts.
Mail works fine, other letters arrive.

I run it
/usr/bin/php7.4 /home/korobok/web/

I tried from under the admin, where there are panel crowns. Doesn’t work either.

I’ve tried reinstalling the panel, but that doesn’t help either.

You can’t activate the cronjob via the UI. After you have added it it will run on default

I activate cron this way. It works according to the log. But I put on 1 minute. It doesn’t work either.

I don’t receive an error message in my inbox. I think it should come?

There should be no “Activate” in the drop down list.

What translations are you using?

I use Russian.

I assume you used a translation software to translate it from Russian to English?[term]=unsuspend&filters[user_login]=&filters[status]=current_or_waiting_or_fuzzy_or_untranslated&filter=Filter&sort[by]=priority&sort[how]=desc

It should mean “Un suspend”

That is why you see the error message “v-unsuspend-cron-job ‘korobok’ ‘2’ ‘no [Error 6]” As the cronjob is not suspended and can’t be “Activated” / Unsuspended" any more…

This is written in Russian in the panel like this: Активировать

After creating a cron as a user, do I need to do something to make it work? Apply some command?

By default the cronjobs will be active and run.

In your screenshot the first command will not work as it is missing the first /

For your information:

Hmm… he is right “Возобновить” - Resume = unsuspend fits better, what do you think?

We will update the translations for next release…

I removed all cron commands. Created a new one as in the screenshot. No command. There are no errors in the logs. But I didn’t receive an email about cron job and cron didn’t work on 14.06 ?

By clicking on the link, the script test works and a notification letter comes to my mail about this.

Translation for this term has been corrected.
New value will be “Возобновить
Thank you for your feedback!

It would be logical to display the status of the cron, so that it is clear whether it is active or not. Then there will be fewer mistakes. But the cron command still doesn’t work for me.

Where can I fix my language file?

Next release is scheduled for Tuesday and we will merge it then…

What happens when you login via ssh and run the command as the user?

What command do you mean? I have no problem unzipping the archive, uploading the file to the database via ssh. I do not observe any problems at work at all, except for crone.