Login fails after ROUNDCUBE update

as said in the title
i saw ROUNDCUBE was updated yesterday in the last HESTIA release
since, connection to webmail fails

Login fails

i’ve tried to renew passwords, i had them sent by notification to check the server would send me the appropriante credentials : nothing does : Accounts accessible yesterday aren’t anymore today …

Check the error log why it exactly fails.

Have tested in 4 different users with upgrades and had no issues

I join. When trying to login for a long-existing user, the following lines are added to the /var/log/roundcube/errors.log file:

[05-Aug-2022 10:13:47 UTC] PHP Warning:  Undefined array key "ssl_mode" in /var/lib/roundcube/program/lib/Roundcube/rcube_imap_generic.php on line 1053
[05-Aug-2022 10:13:47 +0000]: <hd5e3hah> PHP Error: Access denied for new user [email protected] 'auto_create_user' is disabled in
 /var/lib/roundcube/program/include/rcmail.php on line 815 (POST /?_task=login&_action=login)

New or upgrade from 1.6.5

i’ve looked in /var/log/roundcube/errors.log
and checked every log in there
but there is no log since 2 days back

i’ve looked around in other logs… didnt find a thing

i did the upgrade yesterday with apt upgrade of my system 22.04

That might change a lot also with other changes that might not fully executed it is smart to do a new install

new install of what? roundcube? hestia?

Everything as both exim4.conf.template are broken and a few more… Due to changes in both exim4 and other things…

Hi,
I have same problem with login after upgrade from 1.6.5 to 1.6.6. Just new users can not login to webmail

I have found what is wrong currently looking for the “best” fix

3 Likes

@WebsteR @Palch

Please try:

 sed -i "s/\$config\['auto_create_user'] = false;/\$config\['auto_create_user'] = true;/g" /etc/roundcube/config.inc.php
1 Like

browser:

Oops… something went wrong!

An internal error has occurred. Your request cannot be processed at this time.
For administrators: Please check the application and/or server error logs for more information.

Needs to be true;

nano config.inc.php
Search for auto_create_user and add an ; after true

The page is not available
mail.jgfchexrjq.tk is unable to process this request yet.

HTTP ERROR 500

Check /var/log/nginx/domains/webmail.domain.com.error.log

/var/log/nginx/domains/webmail.jgfchexrjq.tk.error.log - empty
/var/log/nginx/domains/mail.jgfchexrjq.tk.error.log - empty
/var/log/nginx/domains/mail.jgfchexrjq.tk.log - don`t empty

nano config.inc.php
Search for auto_create_user

Make sure it reads $config[‘auto_create_user’] = true;

1 Like

I swear:

// Automatically register user in Roundcube database on successful (IMAP) logon.
// Set to false if only registered users should be allowed to the webmail.
// Note: If disabled you have to create records in Roundcube users table by yourself.
// Note: Roundcube does not manage/create users on a mail server.
['auto_create_user'] = true;

Sorry, lost “$config”. Worked!!! Grazie!!!