New user admin2 assigned to admin role, doesn't have all permissions

hey guys

I need to setup user ‘admin2’ for all of my VPS. I had a bit of inconsistency, and I think that some of the syntax in the documentation told me to use the role ‘administrator’ and then I found some examples that used the role ‘admin’. So that was a tiny bit confusing. I think that 2 of the 4 machines accepted the role named ‘administrator’ and the other 2 machines rejected it. Now I’ve got the role set as ‘admin’ for all 4 of these machines.

And on 3 out of the 4 machines I setup admin2 user for, I am not getting the ‘Settings’ button (it looks like a gear box) in the upper right hand corner.

I had previously setup a IPv4 restriction on my firewall AND the user ‘admin’. and then when my IPv4 address changed unexpectedly, I’ve been struggling to get back into hestia for a while now.

Do you guys know how to make the ‘settings’ icon show up so that I can go and edit the configuration for the server?


Does your admin2 has admin privileges?

Settings - Server Settings - System Protections - System Administrator account → Toggle off: “Do not allow other administrators to access Server Settings”

Oh, that makes me feel better.

So how do I do that via the Command-Line? I’m locked out of 3 of my 5 servers right now.

I still don’t know why you guys forced the whole ‘inability to login as root’ I just disagree with that design decision.

Clearly, all 5 of my machines stopped accepting my passwords.
I fixed the firewall rule, I setup another Admin2 user. I can’t see why I somehow don’t have the AUTHORITY to make a new admin user, when I’m root.

I love this software, but It’s been giving me ISSUES for the last 2 months, and I just gotta back into these Control Panels. Thanks

Is THIS the command I need to disable to give admin2 the ‘real’ admin priveleges?

Sorry, I meant to include that

v-change-sys-config-value ‘POLICY_SYSTEM_PROTECTED_ADMIN’ ‘yes’

BTW, I REALLY wish that there was better documentation on ALLLLL of the CLI commands.
I’d be glad to help write it

1 Like

I think I might have found it. I see two arguments

Previously, I had cleared the value for ‘LOGIN_ALLOW_IPS’. But upon further review, I realized I should probably also set LOGIN_USE_IPLIST=‘no’ because I was still having problems logging in. I hope this fixes it. I need to get back to development.