OTP not working

Hey;

I’ve got 6 or 8 hestiaCP machines, and I absolutely love the platform.

on ONE of my machines, I’m having a failure on typing in the OTP for the admin user.
I think that when I ssh in as root, I think that I have a 120 second discrepency in Date/Time between my local machine and the hosted HestiaCP machines.

Most of my machines work perfectly, I just have 1 machine that won’t take my passwords.

Do you guys have any reccomendation on getting the time clocks to sync to a specific machine?
I’m guessing that I have a DNS failure (for that local machine) argh.

Is there a built-in script that will act like nslookup? And then I could start testing for time.ntp.org or something, make sure that the server is going to the correct servers?

Just throwing out ideas.
My hosting company wasn’t entirely helpful with this process.

Any ntp server should work fine but DNS needs to be resolving as it depends on the time…

do you know the best method to tell what NTP server I’m using on Debian11?

do you know any way to reconfigure DNS to default?

I only have 1 or 2 machines with the DNS role, I wish there was an easy way to determine that (via SSH @ root instead of logging in via HestiaCP.

I’ve been locked out for 45 days, and I’ve hit the button to ‘sync clocks’ on Google Authenticator or whatever that option is called.

I wish that OTP worked MUCH differently in the real world.

Hittings the sync clocks on the “Google authenticator” does not work as the app doesn’t connect to the server to sync the times.

https://www.google.com/search?client=safari&rls=en&q=how+to+sync+time+with+ntp+server+in+linux&ie=UTF-8&oe=UTF-8

By default ntp is allready installed.

For DNS server you need to have a valid other wise you will not be able to install updates and so on.

To delete the “otp” key run v-delete-user-2fa user and you can login with it. Without entering a 2fa key

To check what server is being used check:
nano /etc/systemd/timesyncd.conf

1 Like

Thanks so much. Sorry for the delay in getting back to the topic :slight_smile: I’m going to go resolve it now, THANKS