Page not found after creating user and domain

Hestia Control Panel:
v1.1.1
Operating System
Debian 10.3 (x86_64)

I just created a new user on the panel and added the domain.

When accessing the domain the standard 404 error of hestiacp is shown

image

chmod -R 755 /home/USER/web/DOMAIN.com.br/public_html/

image

I don’t know if this is happening to other users

is there a index.php or index.html in the public_html folder? which web template are you using for the domain?

I use the standard version of hestiacp, no package has been changed

HI, this is the correct landing page when you create a new domain. It’s the index.html autogenerated. You can just delete it and replace with the one you wish.

Thank you for the answer.

Yes, the index.html file is created
The case is it is normal to have to give permission to see the index.html page, as shown in the topic opening

Hi @roneycs , no, you should not change permissions. Are you using an unpriviledge user for this domain in Hestia?

I will inform you what I did.
I created a new user on the dashboard
I added the domain
I tried to access the domain and presented error 404

To show the correct page (construction) I had to change the file permission

It’s weird because you did like you should :smiley:
If you recreate a new domani with same user the problem is still there? Just asking… :wink:

All the domains I create are the same.
Different users do the same thing.

Strange default chmod should be 644 and not 755

See https://github.com/hestiacp/hestiacp/blob/master/bin/v-add-web-domain

Is it a new install? What version are you using (1.1.1 ?)

1 Like

Hestia Control Panel:
v1.1.1
Operating System
Debian 10.3 (x86_64)

Is the same group owner for the same user? I mean 1002:1002, 1003:1003, etc?

From what I’ve observed, yes

The only change made was the permission even for the page to be visible

After you create a new domain what are the file perms?
ls -l

2 Likes

first of all: doing a simple recursive 644 or 755 is not a good idea. files and directory should have and might require diferent masks. also: is that system OOB or still the one you already messed a lot with for the stuff from your other questions?

then what @Lupu just pointed out: how do the file-permissions look like on the folders and files before you changed them? did you eventually at some point simply changed the umask or something?

this are really basic things that don’t break just out of the blue on one system while they work without problems for all others. I can only suggest: don’t run commands from any howtos or tutorial from the internet that you don’t understand - even if it is said that it will solve this or that. it simply might mess up your system in other parts you only find out later.

it’s probably time to reinstall your whole box and start from scratch.

1 Like

Best solution is only 3 options…

  1. Goto https://your-hestia-admin-panel/list/user.
  • choose your problamatic user id & click REBUILD WEB DOMAINS & restart whole server.
  1. Create new diff user & try new domain scenario

  2. If above both not helps, seems your server permissions not well. Better flush the whole server & rebuild. Do not attempt to do permission alterations, as it supposed not to be happened here. It happened means, somewhere is fishy.

2 Likes
total 184
-rw-r--r--  1 user-test user-test   405 Apr 20 20:53 index.php
-rw-r--r--  1 user-test user-test    65 Mar 13 17:13 robots.txt
-rw-r--r--  1 user-test user-test  6912 Apr 20 20:53 wp-activate.php
drw-r--r--  9 user-test user-test  4096 Apr 23 21:08 wp-admin
-rw-r--r--  1 user-test user-test   351 Apr 20 20:53 wp-blog-header.php
-rw-r--r--  1 user-test user-test  2275 Apr 20 20:53 wp-comments-post.php
-rw-r--r--  1 user-test user-test  3345 Apr 23 21:12 wp-config.php
-rw-r--r--  1 user-test user-test  3102 Apr 20 20:53 wp-config-sample.php
drw-r--r--  8 user-test user-test  4096 Apr 24 18:50 wp-content
-rw-r--r--  1 user-test user-test  3940 Apr 20 20:53 wp-cron.php
drw-r--r-- 21 user-test user-test 12288 Apr 23 21:08 wp-includes
-rw-r--r--  1 user-test user-test  2496 Apr 20 20:53 wp-links-opml.php
-rw-r--r--  1 user-test user-test  3300 Apr 20 20:53 wp-load.php
-rw-r--r--  1 user-test user-test 47874 Apr 20 20:53 wp-login.php
-rw-r--r--  1 user-test user-test  8501 Apr 20 20:53 wp-mail.php
-rw-r--r--  1 user-test user-test 19396 Apr 20 20:53 wp-settings.php
-rw-r--r--  1 user-test user-test 31111 Apr 20 20:53 wp-signup.php
-rw-r--r--  1 user-test user-test  4755 Apr 20 20:53 wp-trackback.php

image

[email protected]:/home/user-test/web/user-testeibel.com.br/public_html# chmod -R 755 .
[email protected]:/home/user-test/web/user-testeibel.com.br/public_html# ls -ls
total 184
 4 -rwxr-xr-x  1 user-test user-test   405 Apr 20 20:53 index.php
 4 -rwxr-xr-x  1 user-test user-test    65 Mar 13 17:13 robots.txt
 8 -rwxr-xr-x  1 user-test user-test  6912 Apr 20 20:53 wp-activate.php
 4 drwxr-xr-x  9 user-test user-test  4096 Apr 23 21:08 wp-admin
 4 -rwxr-xr-x  1 user-test user-test   351 Apr 20 20:53 wp-blog-header.php
 4 -rwxr-xr-x  1 user-test user-test  2275 Apr 20 20:53 wp-comments-post.php
 4 -rwxr-xr-x  1 user-test user-test  3345 Apr 23 21:12 wp-config.php
 4 -rwxr-xr-x  1 user-test user-test  3102 Apr 20 20:53 wp-config-sample.php
 4 drwxr-xr-x  8 user-test user-test  4096 Apr 24 18:50 wp-content
 4 -rwxr-xr-x  1 user-test user-test  3940 Apr 20 20:53 wp-cron.php
12 drwxr-xr-x 21 user-test user-test 12288 Apr 23 21:08 wp-includes
 4 -rwxr-xr-x  1 user-test user-test  2496 Apr 20 20:53 wp-links-opml.php
 4 -rwxr-xr-x  1 user-test user-test  3300 Apr 20 20:53 wp-load.php
48 -rwxr-xr-x  1 user-test user-test 47874 Apr 20 20:53 wp-login.php
12 -rwxr-xr-x  1 user-test user-test  8501 Apr 20 20:53 wp-mail.php
20 -rwxr-xr-x  1 user-test user-test 19396 Apr 20 20:53 wp-settings.php
32 -rwxr-xr-x  1 user-test user-test 31111 Apr 20 20:53 wp-signup.php
 8 -rwxr-xr-x  1 user-test user-test  4755 Apr 20 20:53 wp-trackback.php

normalized page

This is not as @Lupul requested, there is already a wordpress in it. He asked a ls -l from a frshöy created domain to see the permissions.

sorry

[email protected]:/home/iolenes/web# ls -l
total 4
drwxr-x--x 9 iolenes iolenes 4096 Apr 23 20:35 ioleneseibel.com.br

Hi, it seems you still not getting what ScIT asking…
You should create a new user NOW
You should create a new domain NOW
And then get the ‘ls -l’ output.

But your above is showing 23’april. Also you already changed the folder permissions to ‘drwxr-x–x-751’ which is not correct.
It supposed to ‘551’

1 Like