Php-fpm pool doesn't exist / can't create domain

Ubuntu 18.04 / nginx + php-fpm
On two different servers (hetzner.cloud, vdsina.ru) during installation I get this error.

==========================

Adding required repositories to proceed with installation:

() NGINX
(
) PHP
() MariaDB
(
) Hestia Control Panel

Updating currently installed packages, please wait…/
Now installing Hestia Control Panel and all required dependencies.
NOTE: This process may take 10 to 15 minutes to complete, please wait… |
() Configuring system settings…
(
) Configuring Hestia Control Panel…
() Generating default self-signed SSL certificate…
(
) Adding SSL certificate to Hestia Control Panel…
() Configuring NGINX…
(
) Configuring PHP-FPM…
() Configuring PHP…
(
) Configuring Vsftpd server…
() Configuring MariaDB database server…
(
) Installing phpMyAdmin version v4.9.0.1…
() Configuring Exim mail server…
(
) Configuring Dovecot POP/IMAP mail server…
() Configuring SpamAssassin…
(
) Configuring Roundcube webmail client…
Error: php-fpm pool doesn’t exist
Error: can’t create XXXX.XX domain

==========================

Installation config. But php installed 7.4.1

Define software versions
pma_v=‘4.9.0.1’
multiphp_v=(“5.6” “7.0” “7.1” “7.2” “7.3”)
fpm_v=“7.3”

==========================

[email protected]:/tmp# php -v
PHP 7.4.1 (cli) (built: Dec 18 2019 14:44:22) ( NTS )

==========================

!!!
That is why installing ppa:ondrej/php should be optional and turned off by default.
!!!

This creates a lot of security problems and a broken server during an unexpected php version upgrade.

Cant login to Panel too. Getting error NO LANGUAGE DEFINED or ERR_EMPTY_RESPONSE

PHP message: PHP Warning: session_start(): open(/usr/local/hestia/data/sessions/sess_bhsqnj6r96kmb0fd6dj8jq27ek, O_RDWR) failed: Permission denied (13) in /usr/local/hestia/web/index.php on line 2

First of all: Why a current php version should be unsecure? Also it is not a upgrade, it is a new installation, the current servers will not update to another php version - this has nothing to do with security, even it is more secure to use a up to date version.

The current installer has been patched to install php7.3 only, a few days ago (https://github.com/hestiacp/hestiacp/commit/0b4c0dc8efad5cad41b17498f748324c95d4264f). Do you use a fresh version of the installer?

I am installing from release version:
wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/install/hst-install-ubuntu.sh

The problem is not with the current php version, but that it can be upgraded without any warnings while using ppa:ondrej/php.

The site can use special php modules that are compiled to a specific php version and a site will stop working if there is an unexpected php upgrade.

The current example is the Hestia installation package, which does not work.

I’m sorry, but this is not true: current systems will not be automatically updated, if the system runs php 7.3, it will stay on php 7.3 until you would manualy upgrade the packages. Currently we work on a implementation for this using the v-scripts.

You can’t take hestia as example for a auto upgrade, because this was a mistake from our side: We haven’t set the php version for apache+nginx packages, so it just installed “the current package” - in that way ppa sent out php 7.4.

I just check the php fpm installation now, it’s possible, that the last few changes on the installer has made some mistakes in nginx + php fpm installation.

I can confirm, that the current installer for nginx + php fpm stopped working, I currently check why this happened and will push a fix as soon as possible.

1 Like

It will update. I had this problem already. See:
update-alternatives --config php

By default, option 0 is selected - automatic upgrade. That is, if you use the php package, it will always match the latest php version from the ppa:ondrej/php repository.

Yesterday it was php 7.3 version, and today it is 7.4

See this topic with auto-upgrade php version: https://answers.launchpad.net/ubuntu/+question/432604

Do you speak about a apache2+nginx server or a nginx+phpfpm server?

nginx + php-fpm is the same situation.

Just checked on one of my systems (multiphp), basicly i can confirm this situation, because the package “php” is also installed (currently don’t know why, because it should be php-fpm only). But it looks only php cgi is php7.4, the current web stacks havent changed. can you confirm this? Or did also php fpm udpated himself?

if you install php-fpm package, php will also be installed. It is the cli version which is using to run scripts inside Ubuntu system.

I can not confirm. I always remove ppa:ondrej/php from the Hestia installaton script on working servers.

The release branch has been fixed now, I’ve reverted the changes we did for apache2+nginx - they has caused the issues with php fpm installations. We need to take a deep look into the issues with different php cli versions and auto upgrades on sury repo - but what I can say for now: Current webstack’s php version will not be changed or updated - a update of php cli is possible, basicly you would need to change the default version for “php”-command.

We need to rework the installer for the different php versions, but due to the holidays, we do not have enough devs here.

Can you please recheck the installation and let me know, if all works properly?

This update-alternatives --config php will change not only the cli, but php-fpm version systemwide too.

Many sites using server scripts to function properly (wordpress cron for example). If the cli and fpm versions are different the problems will come.

I’ll check now and let you know in the topic.

I understand, that different php-cli versions can cause issues, also for example with magento 2. But it should not upgrade the pfp-fpm instances, because they were installed with the php version itself (for example php7.3-fpm and not with php-fpm).

As I already wrote: we will do a deep analyze what exactly happened with the php-fpm installations due to the reverted commit and also we try to find a solution for the upgrade issues.

1 Like

Everything is fine now. I changed php-fpm to 7.1 in Hestia installation script and it come without any errors.

[email protected]:~# php -v
PHP 7.1.33-3+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Dec 18 2019 14:53:18) ( NTS )

Perfect, thanks for your feedback and sorry for the troubles we did with the commit :slight_smile:.

We will rework the installer in january and probaly also push v1.1.0 within the same time. Please let us know if you find any other issues.

1 Like

Thank you very much for quick responce and fix!

One more thing.

  1. I try to install with fpm_v=“5.6” (I need this version for old site) in hestia installation script and again got the first message error. Can not get it work. Php 7.4 was also installed by the installation script.

  2. Again try install with multi-php option and got apache2 installed but php-fpm was only selected to install.

For point 1: I think it has installed the php-cli version itself, but the php fpm package would have been setup properly. Please check this with a phpinfo();. You can change the cli version with the following command: update-alternatives --set php /usr/bin/php5.6

For the second point this is quiet easy: If you choose multiphp on nginx+apache2 configuration, it will be solved using php fpm and provide you for every php version a own apache2 template. Just check under edit web -> apache2 template. You also can copy the default one and adjust them if needed.

It is intresting that in 5.6 case, php 7.4 was not installed in the system, but while Hestia installation one of php modules (php-imap) was installed without specifying the 5.6 version. This led to the installation of a module for current (as ppa:ondrej/php repo) php 7.4 and not for 5.6.

After that, Hestia was not able to configure php-fpm correctly.