Regarding DNS problem

i have just install Hestia
and its install on a domain srv.xxxx.xx and then i added a user and a webservice on the same main domain but the root domain xxxx.xx and a couple more liek mail.xxxx.xx imap.xxxx.xx

then i tried to ping them no response (and yes i have added the dns in my network conf)
then i added another user and another domian vvxx.xx mail.vvxx.xx and so on the ni tried to ping that domain and they all work fine but i the first one does not seem to work

The first thing I would is did update you DNS records / Name server at your hosting provider?

nope it is only for local dns on the network

But thanks anyways :grinning:

Does the dns lookup works, do you get the proper ip addresses if you try to ping?

The hestia server is on and the dns records are pointing to
and the dns settings in the pc network crad is set to and
I can ping the other domains but not the first one (the one that the main service is on srv.xxxx.xx)

It should be working

I’m sorry, but this sounds like a local issue, that isnt related at all to hestia - we can’t help you out here :slight_smile:.

What are you talking about the hestia system is acting as the Local DNS server so yeah its is Hestia Related

Probaly it is related to a configuration issue, I do not know what your target is to reach with that project, but infact that it doesnt work leads probaly to a missconfiguration.

As you can find in the following posting, we see hestia as solution for sysadmins with a decent knowledge about how to handle serversystems: Please read this, before you start!

So if you want to have help, please provide more informations than what you wrote in your first post. Basicly, you didnt wrote how you setup the dns, just that you added the “dns to your local network conf” - whatever this means. If you want to use hestia as central dns server you also could setup a resolver and so on, but this depends on your target you want to reach.

So a first start would be to debug with nslookup/dig requests on the hestia server, probaly check the bind log if the requests are showed up properly.

Currently, due to the lack of informations, it is just not possible to help you. Also I can confirm that hestia doesnt have any problem in its bind configuration, it works properly - this leads to a local (configuration) issue.

I hope you understand now my position after the long explanation a bit better.

Thanks ill try that…

1 Like

Hi there the bind config looks ok but it does not recognize the dns request just as unknown
but the others domains works fine

i have just install a server with the vestacp with the same config and that works so there is somthing holding the dns request for domain 1 back

My setup
Hestia server admin (Main server.domain 1 ) This can be pinged

              User01 domain 1      web dns mail      This can not be pinged        
              User01 domain 2      web dns mail     This can be pinged
              User01 domain 3      web dns mail     This can be pinged
              User01 domain 4      web dns mail     This can be pinged

@crazytoo Without the proper information we can’t help you. We are all working with love on this project but we are not able to supply full support on any issues.

We are working on this project with the main reason it makes our work as system admin easier and faster. And I really don’t care if it benefits other users with the changes we / I make in the source code. But at least I hope it we be an improvement for the software and and hopefully other person are going to use the software.

And publishing the source code for everybody. “As it is” will mean that every body can use it on his own behalve with some limitations.

How ever we don’t give support on any user and you can’t compare it with Plesk, Cpanel or Plesk. We are not obligated to support any thing.

if you need support at least provide us any information about the current setup / install string and other information.

With the current information I can’t help you. Or there is somebody that need to access to your server. But that will be paid support.

1 Like

Okay then i dont really know what info you want
The server is a freashly install debian 9 and the installation is
typed the mail for admin

then rebooted

created user1 with domain ( (Alias , web dns mail
created user1 with domain ( (Alias , web dns mail
created user1 with domain ( (Alias , web dns mail
created user1 with domain ( (Alias , web dns mail

the server has

there is nothing more configure at all

from a windows pc the ip settings gateway and the dns

when i ping i get the reply
when i ping i dont get the reply this is the only thing that is not working
when i ping i dont get the reply this is the only thing that is not working
when i ping i get the reply
when i ping i get the reply

All the others works fine

the bind have all the zones and they point to the home/dom1…2…3 config

and it should be working

but maybe somthing breaks when the the main server has the same domain as user1
i can see it

What is it for? Why not just add the rest of the aliases to the first domain?

Alliassen for different domains can be better kept separate.

And I think he just copied the text 4 times and he forgot to alter them… See Regarding DNS problem

  1. From the server try to ping the domains.
  2. Check in the admin account if there is DNS zone present for Domain 1
  3. check if there is any DNS zone present for Domain 1 in user account 1.

There is no issue with hosting a domain under account one and use the as Control panel.

As I wrote already: You need to debug, why your bind/named server isnt answering for your domain. Also check your log files, there is a possibility that a zone failed to load (probaly related to your missing dns zone).

In addition, ping isnt a good tool to check if name resolution is working - of course you can use it, but probaly you can debug better with nslookup or dig followed by your target (hestia) server.

What exactly is in the log (probaly syslog), when you do a nslookup/dig on the domain? Did you do a cat /var/log/syslog | grep to see if there are any failed zone bindings? If you have something there, please post the log anonymized.

Hestia is still a fork of vesta, currently there is no change to the dns stack, so hestia and vesta are still equal here. If it works in vesta, it should also work in hestia.

I hope you understand, that it is hard to help you out with only have some drawings of your planed setup. Also I still miss what exactly your plan is - according to your informations, you want to build up a local only dns and webserver?

Hi there agian
Yes that the reason i think it should be working

are dns domains showing up when listing them?
v-list-dns-domains user1

what about listing dns records?
v list dns records user1 domain1

I Just deleted the dns on the admin account
then i deleted the domain that had the issue
and created it one more time

now the server is happy and son is the admin thanks for your help

one more thing my hestia seems a little slow anything i can do

Glad to hear you solved the issue.

‘Hestia seems slow’ could mean many things, you need to be more specific. Is a hosted site slow or the panel? are all pages slow or just a few if so which ones? what does slow mean 500ms or 5s? slow compared to what? what specs is you server?, how far are you from the server? how is the cpu usage? and so on…

PS: If you want to better understand the perspective of someone that is answering tehnical questions, I highly recommend this short clip

1 Like