Regular users can't login to panel

Hi, I’m Gerard!

We are on v1.5.7
we are experiencing issues with regular users. Any of them could login to panel due error Invalid username or password.
I tried to reset password trough panel or script v-change-user-password with any error but when try to login same error.
I checked the error log /usr/local/hestia/log/system.log without errors and auth.log
2022-01-28 12:55:15 GerardT failed to login
But after password change… error again.
I can log into the panel trough admin to regular user but any regural user could.
The check box at user config “Do not allow user to log in to Control Panel” is unchecked
The v-check-user-password script giving me errors:
/usr/local/hestia/bin/v-check-user-password: line 65: [: y: integer expression expected
/usr/local/hestia/bin/v-check-user-password: line 67: [: y: integer expression expected
Error: password missmatch

LOGIN_DISABLED=‘no’ at user.conf too

Anyone could help me?


Update, it happens with old orr new users. Only admin could login

What OS do you use?

If I am right it will be Debian 11?

experiencing the same thing on debian 11.

Disable yescrypt in


make sure the line looks like:

password [success=1 default=ignore] obscure sha512

It is probally currently like:

password	[success=1 default=ignore] obscure yescrypt
1 Like

Thanks!!! It works! you saved my day!!

We will add an commit to check if yesscrypt is used (And warn the user) . And in the future allowing to login via yescrypt …

1 Like

Of course you’re right!

Hi everyone,
after updating to version 1.5.7 and restarting the server I can no longer enter the control panel, I have seen the file
[success=1 default=ignore] oscure sha512
and it is correct and I am using debian 10.11
Can someone help me?
Thanks so much

Check /var/log/hestia/auth.log en /var/log/hestia/error.log

Debian 10 should not be affected by the bug above…

Thanks for the quick reply, there are no errors in the logs.
In order not to waste much time looking for the problem I restored from a backup of the previous day and now it works perfectly.
I honestly didn’t understand what could have happened.
if it happens again then we will look for the cause.
Thanks again for the support, knowing that someone is available is very encouraging.
Good day

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.