Reinstall roundcube, is it possible?

Hi there, how’s it going?

I’m facing a problem, I tried to update my RoundCube to an updated version (1.4.11) following a guide posted here on the forum but not work as I expected.

I can access to my webmail service but some functions like menus, options, logout doesn’t work or do it in a strange way, so I did a mess (and now I have roundcube folders and files everywhere etc/roundcube - usr/share/rouncube - var/lib/roundcube) :sweat_smile: .

So, is it possible to uninstall complete roundcube and install the default hestia package again from the console? Because I’ve tried to put the backup files again but that not worked.

I’m currently working with Debian 9 on my server.

Thanks so much,
kind regards.

Edited and Solved

Did it my last try and was successful!

Follow these steps:

  1. I followed this guide to update to the last roundcube versión (stable) 1.4.11 RoundCube Upgrade Procedure
  2. I did the settings changes on /etc/rouncube/ (like theme, plugins and license-key)
  3. Run the following command php /usr/share/roundcube/bin/ (also fixed the error with mailboxes not showing any messages)
  4. Now all works like a charm and I have my upgraded Rouncube on Hestia!

We release 1.4.0 soon and this includes an upgrade test to the last version