Roundcube Upgrade Procedure


Noticed that there is a new roundcube release ver. 1.4.0. I’m using Debian 9.

Does Hestia have any manual roundcube upgrade instructions?

The below are instructions for Vesta from their forum. Will these work for Hestia?

Re: Roundcube Update

by **[Youp]» Wed Jul 23, 2014 4:07 pm

*** Save Original Files

mv /usr/share/roundcube/ /usr/share/roundcube_bk/
cp -R /var/lib/roundcube/ /var/lib/roundcube_bk/

*** Download Roundcube and prepare the folder

tar xvf rcm[NAME_MAY_DIFFERS].tar.gz
cp -R rcm[NAME_MAY_DIFFERS]/ /usr/share/roundcube/

*** Create config files (and symlinks)

mkdir /etc/roundcube/config
cp /usr/share/roundcube/config/ /etc/roundcube/config/
ln -s /etc/roundcube/config/ /var/lib/roundcube/config/
cp /usr/share/roundcube/config/ /etc/roundcube/config/
ln -s /etc/roundcube/config/ /var/lib/roundcube/config/

*** Copy plugins and skins

rm -R /var/lib/roundcube/plugins/
rm -R /var/lib/roundcube/skins/
cp -R /usr/share/roundcube/plugins/ /var/lib/roundcube/plugins/
cp -R /usr/share/roundcube/skins/ /var/lib/roundcube/skins/

1 Like


This procedure worked for me.
If uprgading from 1.3.6 you can skip symlinks creation, as they both already exist.
No issues with 1.4.0 so far.


1 Like

Seems to have worked for me as well.

Only change I made was to the below:


cp /usr/share/roundcube/config/ /etc/roundcube/config/

And, you were correct that the symlinks already existed.


I’m using HestiaCP 1.2.0 for mail server. I’ve installed it 4 days ago. Can i update Roundcube for last version (1.4.7) and will this procedure work for my enviroment?

Thanks in advance.

Yes. I just upgraded to Roundcube 1.4.7 on HestiaCP 1.2.0.

Same process.

1 Like

We are working on a new Installer including a installer that will download Roundcube from source instead depending on packages that are often out dated

For example

Only then for Roundcube. Estimated release data Unknown…


Thanks! Works fine after update.

eris, It would look great!

Upgrade to 1.4.8. did not work using above process. End up with. Page not found, 404.

Did anything change in the back end? I know there was discussion on changing the way roundcube is updated.

I attempted the upgrade to 1.4.8 as the roundcube apt-get updates break the webmail (known issue at least for Deb 9) and this has always worked in the past to fix.

Edit: should also mention that I am on Hestia v1.2.3 now as that updated as well. Also attempted to reinstall back to roundcube 1.4.7 but that has same error. (404).

Found some strange anomalies.

Can access webmail but only using unsecured access via
I can log in, but webmail login page is the older template style.

if I use secure
I just get a Success your new web server is ready to use message.

if I use
Then it I get a login page (the newer style one) but it fails (password invalid) even though the same password works in insecure method. (???)

And, If I try
Then I get the, page not found 404 error.

So something weird is going on.

Sid you enabled mail ssl for the requested domain? Also manual roundcube arent supported from hestia, we currently still work on a supported upgrade process.

I just activated the mail SSL and have access that way. Securely. Thanks for the recommendation.

In the past I would just go to roundcube via

So something changed, but all is well as long as I have the alternative.

I look forward to the supported process. Still need to resolve why the roundcube updates are breaking it, but honestly haven’t had time to research that.

Thanks again for the help.

In the future we probably need to drop the use of APT for phpmyadmin, phppgadmin and Roundcube and just download the version and update it self. This is the only stable way to not depend on OS versions lacking behind.

the /webmail alias has been dropped, you gonna beed to use webmail.domain.tld.


Why it is dropped?

due to the rework if the mail ssl engine.

1 Like

Maybe good idea is to use one ssl for website and mail? I mean like directadmin do… They generate one letsencrypt ssl for domain and some defaults subdomains…

And good idea if you enable ssl for domain, it too will be enabled for mail…

ssl for mail is by design separated from the current web stack, so you can run it aswell on a different server without much hassle.


It wouldn’t be easier if one of us integrate the higher version of Roundcube into HestiaCP installer instead of current lower version?

1 Like

Yes it is true.

How ever we need first disconnect the current connection with atp. But as often the time is the limited factor