Sieve for roundcube

There was a previous thread asking about implementation of Sieve in Hestiacp. I tried following that to enable sieve in roundcube, without any luck. Is there a tutorial on how to implement sieve related specifically to Hestia. The other tutorials i’ve read just break stuff and I’m not that good at modifying servers. I can’t find anything in my logs except a log from NGINX referencing the failed connection to sieve, but I have no idea why:
./nginx/domains/webmail.ie.com.log:...10 - - [15/Jan/2021:02:27:30 +0000] “GET /?_task=settings&_action=plugin.managesieve HTTP/1.1” 200 2122 "https://webmail.i****e.com/?_task=settings" “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.2 Safari/605.1.15”

I really need help.

I’m trying something else. I think the problem was the apt repository for dovecot sieve is old and incompatible with PHP 7

EDIT: don’t think that’s the problem. And tis is the only other error I can find:
[15-Jan-2021 21:37:30 +0000]: PHP Error: Error loading template for managesieve.managesieve in /usr/share/roundcube/program/include/rcmail_output_html.php on line 760 (GET /?_task=settings&_action=plugin.managesieve)

We can’t provide official any support for the integration you try out.

Well that’s all fine, but so many people try to set up sieve that it sure would be nice if there was a tutorial. Even Vesta does that, but their tutorials won’t work one Hestia.

Ok, so where do I go for help. I thought this was the place where Hestiacp users hang out. If I can’t ask other users if they have a solutions, then this seems like a pretty unfriendly place. It seemed ok for users to talk about non-Hestia “integration” here: What about implementing dovecot sieve?.
There’s a whole bunch of stuff on the forum where people are asking for general help. Another example is upgrading roundcube. The upgrade is an “integration” that is not is not part of Hestia, yet it was fine for people to discuss that. I’m very disappointed in your response.

Hmmm. The only discussions I found about that specific error message talked about it being a problem with changing the skin of Roundcube. Did you happen to do something with the skin?
See this thread:

1 Like

@baxterdmutt Don’t know why you’re triggered that hard - probaly because the auto lock feature, this wasnt susposed to cancel any discussion about it. It is just an integration we don’t support officially, so I removed now the solve mark which itself will remove the auto lock feature.

As written, ofc it’s fine to discuss about, just be informed that you can’t expect support from the hestia team if something hardly fail due to the used modifications.

PS: Roundcube will be undocked from the apt repository and installed from source with the next release.

PPS: i just increased the auto close timer to 30 days, so it doesnt look like we want to limit anything. The idea behind the auto close is that users dont revive 10 month old threads and generating notifications - sometimes it’s just better to create a new topic.

1 Like

OK thanks

I upgraded roundcube so that it would work better with mobile devices. So yes, that means the skin changed to elastic. But I didn’t make changes to the skin myself.

EDIT: Thanks. That helps, if I copy the skin “larry” from managesieve/plugins/skins/larry to managesieve/plugins/skins/elastic the issue goes away. The problem now is the output is not pretty and I don’t think it works (but the error is gone). Has anyone been able to find, or is anyone able to modify a skin to work with elastic?

The only skins I’m showing from the Roundcube package in the Debian 10 repo are “Classic” and “Larry”, and it’s set to use Larry. Try editing /etc/roundcube/config.inc.php and changing the skin in the following line:

$rcmail_config['skin'] = 'larry';

You are able to manually do an upgrade and the it will also add the new skin “Elastic” Have to say it is much better. We are currently working on an system that can upgrade to 1.4.10 and undock atp. As is causing when updating to a new version…

The Debian repository for Roundcube is ancient. Not sure why Debian doesn’t upgrade to 1.4.10. That has been the Roundcube stable for quite a while. Elastic is the default skin. The problem is manageieve has never been upgraded and doesn’t have a skin for elastic. So, if you are looking at upgrading to 1.4.10, it will break anyone’s managsieve unless that missing skin is fixed. I’d offer to work on that skin, but it’s outside my skill set.

The current plan is to provide a optional upgrade script, which disables roundcube apt packages and installs it from source. As the modification isnt officially supported, we can’t take any warranty for the upgrade process. I would suggest anyway to disable the auto updater on heavely customized systems.

It is still a manual upgrade. For the small amount of users we can’t hardly made exceptions. All the official themes will get installed and further upgrades leave the changes in the new installer in his place.

1 Like

I think you are missing my point. If HestiaCP is planning on using Roundcube-stable (which is 1.4.10) then the elastic theme is built into it. The problem is, the managesieve plugin does not come with the elastic theme, so it will break.

Yes but if 99 % wants to have Elastic theme and 1% uses Sieve… Why should we leave it to version that is hopeless outdated. Sieve plugin hasn’t been updated for 5 years. You are free to not manually upgrade or change your skin to Larry.

$config['skin'] = 'larry';

It still works fine

2 Likes

Do you have any tips for the installation of the Elastic skin? I have looked at the roudcube site and it points to this: roundcubemail/skins/elastic at master · roundcube/roundcubemail · GitHub
Since i am a novice with compiling *nix code, I am cautious to attempt on my one and only hestiacp host without some guidance.

Agree, I would be super happy with Elastic theme as default webmail UI. Currently it sucks bad on mobile devices… like real bad :frowning:

We will supply an safe and tested bash script to help you migrate …

We will backup the roundcube database. Then apt remove and then install it from source and fix the correct settings. Just wait until 1.4 release

1 Like

The chances are the skin is already installed, and you just need to activate it. Try
ls /usr/share/roundcube/skins
If you see the directory ‘elastic’ in there, the skin is present on your server. In which case you’ll need to edit /etc/roundcube/config.inc.php and change the line
$rcmail_config[‘skin’] = ‘larry’;
to
$rcmail_config[‘skin’] = ‘elastic’;
For me, that was on line 688, so:
sudo nano +688 /etc/roundcube/config.inc.php
If anything breaks, then you can just change it back.

1 Like