SSL for www domain


I am trying to add SSL to my www domain, but its only currently for the non www domain. Is there any way to add it in the command line? Because I get this error " Error: Let’s Encrypt validation status 400. Details: Unable to update challenge :: authorization must be pending" when trying to add it via the panel.

My website is also not showing up under www, only non www??

Hi DBn,

As you already have a certificate for the non-www alias, lets encrypt will fail.

just add your www alias to the aliases section of your non-www domain. Take a look at this example.

1 Like

My domain is “

Alias is “

I deleted the certificates and now none of my domains have SSL or can obtain a certificate because of “Error: Let’s Encrypt validation status 400. Details: Unable to update challenge :: authorization must be pending”

I remove and added alias back, I get error " Error: web domain doesn’t exist". I checked the DNS tab and is there (shouldnt it be with www?). But I control my domains records from the domain registrar, not sure if DNS on Hestia is required?

The same thing happened to me, what I did is stop that domain and start it again from the hestiacp control panel -> WEB — and in the domain that gives you the error, there is a STOP and a start, from there you can stop this domain that gives you problems (It is in the same site that you can disable the web domain)

I couldnt find that option to stop/start a domain. Only apache2 in admin panel and restarting the whole server. Nothing worked :frowning:

my website isnt even showing. I cant even delete the webdomain to restore from backup!

EDIT - Please advise, I dont want to reinstall Hestiacp

Chech the status of your services like nginx and/or apache2.

There is a problem with nginx it seems, apache2 is fine. However, when I go to the folder to remove the pem file so nginx can start, its not there. Basically telling me that my domain doesnt exist.

Feb 17 16:53:24 systemd[1]: Starting nginx - high performance web server...
Feb 17 16:53:24 nginx[11140]: nginx: [emerg] cannot load certificate "/home/dbn/conf/web/": BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/home/dbn/conf/web/','r') error:20
Feb 17 16:53:24 systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
Feb 17 16:53:24 systemd[1]: nginx.service: Failed with result 'exit-code'.
Feb 17 16:53:24 systemd[1]: Failed to start nginx - high performance web server.


When you get no answer to your latest post, it either means that noone has anything more to add to the conversation, or noone currently has the time to answer it. We all have our day-jobs and other obligations, so there are days when we have no free time to read the forum. Also try to remember that this forum accommodates people from different time zones.

Now let’s get back to the problem. As you saw, nginx could not start because it cannot load the certificate.

Go to the web domain, uncheck the boxes about certificates and save the domain. Then check again if nginx is having any issues.


1 Like

I did that before and had the same issue as above. “Error: web domain doesn’t exist”

I don’t think this is an excerpt from the nginx log file. My suggestion was to check nginx log file for errors, not try to get a certificate yet. Any way, since I don’t have info about errors in nginx log, I will suggest something else.

  1. Completely remove web domain (if you have files in there, backup them up 1st)
  2. Complete remove DNS zone (take notes of any custom settings you may have)
  3. Create web domain (not and check the box to create DNS zone. Do NOT select any boxes about certificate creation.
  4. Make sure that you can visit the default page visiting both and in the browser
  5. Go back to web domain and request certificate

These are the only erros from the nginx log, its the same error as above that I posted about the .pem file.

2021/02/20 05:43:43 [emerg] 19364#19364: cannot load certificate "/home/dnb/conf/web/": BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/home/dnb/conf/web/','r') error:2006D080:BIO routines:BIO_new_file:no such file)

2021/02/15 08:11:29 [error] 14130#14130: *40697 connect() failed (111: Connection refused) while connecting to upstream, client: IP, server: _, request: "GET / HTTP/1.1", upstream: "http:// Server_IP:8080/error/50x.html", host: "www.domain[dot]com"

Numbers 1 - 3, as mentioned, I cannot delete, rename in cli or do anything to the domain, I keep getting " Error: web domain doesn’t exist"

What is the output of the following commands when you enter them via SSH logged in as root?

  1. v-delete-web-domain USER
  2. v-delete-web-domain USER
  3. v-delete-dns-domain USER
  4. v-delete-dns-domain USER

1 - 3, Error: web domain doesn't exist or Error: dns domain doesn't exist I tried both www and non www.

Number 4 looks like it worked. Then I tried numbers 1 - 3 again and it was the same output.

EDIT: I also used v-list-web-domain however I got domain doesn’t exist for non www.

v-list-web-domain dbn
IP: server IP
DOCUMENT_ROOT: /home/dbn/web/
SSL: yes / same
TEMPLATE: default
DISK: 3454
BW: 1000
TIME: 01:00:10
DATE: 2020-11-01

v-list-web-domains user
will list all domains

By accident using an idn / punny code domain?

DOMAIN IP TPL SSL DISK BW SPND DATE server IP default yes 3454 1000 no 2020-11-01

No, its a one word domain, no hyphens or anything.

I reinstalled Hestiacp and found that when adding the www. portion of my domain under web it didn’t add the “www.” to the domain or the folder in the user’s directory. Not sure if this is a bug, but it did create the www. domain last time as well as with www. in the directory name.

One more thing, as a test, I removed the domain that failed to use “www.” and tried to re-add it, it gave me the same error as before “web doesn’t exist”.

I tried this with non www, adding and removing, no issues. I thought you should about this, maybe its a bug.

for domain.tld it will add ww.domain.tld as alias, for www.domain.tld it will handle it as subdomain and does not add the www alias (which would be www.www.domain.tld) - all good here.

I’m not talking about the alias. This part here in the image. I added and it didn’t save it as that, only as, unless last time when I was able to save it as was the glitch? What about the web domain doesn’t exist?