Version 1.2.0 Release Candidate 2

Hello everyone,

We’ve compiled a second release candidate of version 1.2.0, which should resolve the previous issues that some users faced during the upgrade process. If no issues are found with this build over the weekend, we will release it to production on Monday, July 6, 2020.

Download: https://apt.hestiacp.com/beta/hestia_1.2.0_amd64.deb
Install: dpkg -i hestia_1.2.0_amd64.deb

If you run into any issues, please file an issue report on GitHub.

Thank you,
The Hestia Control Panel development team

2 Likes

404 for me link is not working

Thanks for reporting. Will report it internally…

I’m using 1.2.0 RC on my Ubuntu 20.04… no issues found till date, do I need to update or not ? because I’m using it on a production server.

No, there is no need to reinstall it - we “only” fixed issues during the upgrade procedure.

@dyrer the link has been updated and should work now.

2 Likes

Hi
I used v1.2 on Ubuntu 20 before this RC2.
Do I need to do anything to update RC1 to RC2?

No, This RC is only for persons using Hestia 1.1.1

If you have updated to 1.2.0 and there are any issue please report them.

1 Like

4 posts were split to a new topic: Rouncube configuration lost due to package upgrade

Wait now. I’m a little bit confused with that version things.

My panel is v1.1.2, and here in topic the name is v1.2.0

so dafaq?

@Amadex, what package version do you have for the core hestia package when you navigate to Server > Updates?

Fresh Ubuntu 20.04 OS

wget https://raw.githubusercontent.com/hestiacp/hestiacp/master/install/hst-install-ubuntu.sh
wget https://apt.hestiacp.com/beta/hestia_1.2.0_amd64.deb
    indent preformatted text by 4 spaces
bash ./hst-install-ubuntu.sh --with-debs /root --apache yes --nginx yes --phpfpm no  --multiphp yes --vsftpd no  --proftpd yes --named yes --mysql yes --postgresql no --exim yes --dovecot yes --clamav no --spamassassin no --iptables no --fail2ban no --quota yes --api yes --lang en --hostname hotnamehere --email emailhere --password password --force yes

  _   _           _   _        ____ ____
 | | | | ___  ___| |_(_) __ _ / ___|  _ \
 | |_| |/ _ \/ __| __| |/ _` | |   | |_) |
 |  _  |  __/\__ \ |_| | (_| | |___|  __/
 |_| |_|\___||___/\__|_|\__,_|\____|_|

                      Hestia Control Panel
                                    v1.2.0


====================================================================


The following components will be installed on your server:

   - NGINX Web / Proxy Server
   - Apache Web Server (as backend)
   - Multi-PHP Environment
   - Bind DNS Server
   - Exim Mail Server
   - Dovecot POP3/IMAP Server
   - MariaDB Database Server
   - ProFTPD FTP Server


====================================================================


Would you like to continue with the installation? [Y/N]: Y
Installation backup directory: /root/hst_install_backups/030720200317
Installation log file: /root/hst_install_backups/hst_install-030720200317.log

Adding required repositories to proceed with installation:

(*) NGINX
(*) PHP
(*) Apache2
(*) MariaDB
(*) Hestia Control Panel

Updating currently installed packages, please wait...-
Now installing Hestia Control Panel and all required dependencies.
NOTE: This process may take 10 to 15 minutes to complete, please wait...                                                                                                                                                                                                                                                    \
Error: apt-get install failed
[email protected]:~#

Alright after a reboot, tried again and it’s working fine.


1 Like

i tried to change the php version to php 7.4 and i’m getting this error

so i’ve gone to Configure Server and deselect php 7.4 (save) then select php 7.4 (save) and after that it was working fine.

https://hostname:8083/edit/server/

image

This was clean install on Ubuntu 18.04, on 1. July 2020.
I’ve used this: https://gabizz.github.io/hestiacp-scriptline-generator/

This is the 1.1.1 interface…

If you have used the command on wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/install/hst-install.sh it will download from the release…

@Amadex, in this case it’s a configuration file error (the version was initially set to be 1.1.2 early in the development process). You can run nano $HESTIA/conf/hestia.conf and change the VERSION variable to 1.1.1 so that it aligns correctly with the package version.

1 Like

Fixed an issue which used 1.1.2 as “new” version number due to the branch reset: https://github.com/hestiacp/hestiacp/commit/a73ff16889ba0714474734774354e8b7a5321012 Also adjusted the upgrade script that the 1.1.2 version also gets an update to 1.2.0: https://github.com/hestiacp/hestiacp/commit/a85de3266547ca820daa63f0919ff8e4f3f25437

Try to update from the git master, have errors :

(!) The latest version of Hestia Control Panel is already installed.
Verifying configuration…

() Updating Roundcube configuration…
(
) Updating exim4 configuration…
() Updating Apache2 configuration…
(
) Updating File Manager configuration…
() Updating NGINX configuration…
(
) Updating public_(s)html ownership…
/usr/local/hestia/func/upgrade.sh: line 163: [: missing `]’
/usr/local/hestia/func/upgrade.sh: line 163: 1.2.0: command not found
(!) phpMyAdmin v5.0.2 is already installed, skipping update…
() Rebuilding domains and account for user: admin…
(
) Restarting services…

Thanks for reporting, just fixed the issue, can you try it again?